View mode: basic / threaded / horizontal-split · Log in · Help
April 01, 2008
[Issue 1967] New: getDirName does not seem to use altsep on windows
http://d.puremagic.com/issues/show_bug.cgi?id=1967

          Summary: getDirName does not seem to use altsep on windows
          Product: D
          Version: 1.028
         Platform: PC
       OS/Version: Windows
           Status: NEW
         Severity: normal
         Priority: P2
        Component: Phobos
       AssignedTo: bugzilla@digitalmars.com
       ReportedBy: jason@spashett.com


string filename = `data/models/comet/comet.obj`;
getDirName(filename);

returns "" which I think is incorrect since the "/" path separator is valid for
system calls.

string filename = `data\models\comet\comet.obj`;
getDirName(filename);
returns `data\models\comet` which is correct.


--
April 25, 2008
[Issue 1967] getDirName does not seem to use altsep on windows
http://d.puremagic.com/issues/show_bug.cgi?id=1967


jason@spashett.com changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
            Status|NEW                         |RESOLVED
        Resolution|                            |FIXED




--
May 11, 2008
[Issue 1967] getDirName does not seem to use altsep on windows
http://d.puremagic.com/issues/show_bug.cgi?id=1967





------- Comment #1 from bugzilla@digitalmars.com  2008-05-11 04:16 -------
Fixed dmd 1.029 and 2.013


--
Top | Discussion index | About this forum | D home