January 06
https://issues.dlang.org/show_bug.cgi?id=20562

Mathias LANG <pro.mathias.lang@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |pro.mathias.lang@gmail.com

--- Comment #11 from Mathias LANG <pro.mathias.lang@gmail.com> ---
I'm tempted to close this, as `OutOfMemoryError` cannot be reliably bisected and there's no "action point" here.

Don't get me wrong, the compiler IS using too much memory, and it IS absolutely a problem (I run into it every week at least).

But it's a structural problem that needs to be addressed, and for the time being the best way to deal with it is to throw `-lowmem` in your dmd.conf.

How does that sound ?

--
January 06
https://issues.dlang.org/show_bug.cgi?id=20562

--- Comment #12 from JR <zorael@gmail.com> ---
(In reply to Mathias LANG from comment #11)
> I'm tempted to close this, as `OutOfMemoryError` cannot be reliably bisected and there's no "action point" here.
> 
> Don't get me wrong, the compiler IS using too much memory, and it IS absolutely a problem (I run into it every week at least).
> 
> But it's a structural problem that needs to be addressed, and for the time being the best way to deal with it is to throw `-lowmem` in your dmd.conf.
> 
> How does that sound ?

Yes, I can solve it for myself that way, but it becomes somewhat of a barrier of entry to ask users to please change their global settings to be able to compile my project.

Is https://issues.dlang.org/show_bug.cgi?id=20699 very difficult to solve? I already set up build configurations like `application-lowmem` for the purpose, they just effectively don't do anything yet.

Can a dmd.conf in the working directory append to DFLAGS from the system-wide /etc/dmd.conf? Instead of overriding?

> DFLAGS+="-lowmem"

--
January 07
https://issues.dlang.org/show_bug.cgi?id=20562

--- Comment #13 from JR <zorael@gmail.com> ---
I may have come across as unappreciative, which was not my intention.

(In reply to Mathias LANG from comment #11)
> But it's a structural problem that needs to be addressed, and for the time being the best way to deal with it is to throw `-lowmem` in your dmd.conf.
> 
> How does that sound ?

Right now I am unable to reproduce the error (2.095), but I only did a casual test. Regardless, please close this if the issue is known and having an open bug report about it only amounts to noise.

--
February 18
https://issues.dlang.org/show_bug.cgi?id=20562

RazvanN <razvan.nitu1305@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
                 CC|                            |razvan.nitu1305@gmail.com
         Resolution|---                         |LATER

--
Next ›   Last »
1 2