View mode: basic / threaded / horizontal-split · Log in · Help
September 21, 2006
[Issue 359] New: configure bug with multi-os-directory
http://d.puremagic.com/issues/show_bug.cgi?id=359

          Summary: configure bug with multi-os-directory
          Product: GDC
          Version: 0.19
         Platform: Macintosh
       OS/Version: Linux
           Status: NEW
         Severity: normal
         Priority: P2
        Component: glue layer
       AssignedTo: braddr@puremagic.com
       ReportedBy: afb@algonet.se


It seems that configure picks the wrong multi-os dir:
phobos_toolexecdir = ${libdir}/gcc/${host_alias}
phobos_toolexeclibdir = /../lib64
toolexecdir = $(phobos_toolexecdir)
toolexeclibdir = $(phobos_toolexeclibdir)

Should have been /usr/lib/../lib64 (i.e. /usr/lib64),
but seems that it used the wrong variable for that ?
On non-multi targets, the multi-os-directory is "."
so that escaped this bug (due to different code path)


--
September 21, 2006
[Issue 359] configure bug with multi-os-directory
http://d.puremagic.com/issues/show_bug.cgi?id=359





------- Comment #1 from afb@algonet.se  2006-09-21 07:37 -------
Created an attachment (id=30)
--> (http://d.puremagic.com/issues/attachment.cgi?id=30&action=view)
gdc-0.19-multi_os-dir.patch


--
November 25, 2006
[Issue 359] configure bug with multi-os-directory
http://d.puremagic.com/issues/show_bug.cgi?id=359


braddr@puremagic.com changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
        AssignedTo|braddr@puremagic.com        |dvdfrdmn@users.sf.net




------- Comment #2 from braddr@puremagic.com  2006-11-25 15:08 -------
Mass reassignment of gdc bugs from me to David.


--
December 17, 2006
[Issue 359] configure bug with multi-os-directory
http://d.puremagic.com/issues/show_bug.cgi?id=359


dvdfrdmn@users.sf.net changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
            Status|NEW                         |ASSIGNED




--
March 09, 2007
[Issue 359] configure bug with multi-os-directory
http://d.puremagic.com/issues/show_bug.cgi?id=359


dvdfrdmn@users.sf.net changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
            Status|ASSIGNED                    |RESOLVED
        Resolution|                            |FIXED




------- Comment #3 from dvdfrdmn@users.sf.net  2007-03-08 20:17 -------
Fixed in release 0.23


--
Top | Discussion index | About this forum | D home