December 16, 2011
http://d.puremagic.com/issues/show_bug.cgi?id=7119

           Summary: In the 1.072 zip osx.d is in the wrong folder
           Product: D
           Version: D1
          Platform: All
        OS/Version: Mac OS X
            Status: NEW
          Severity: regression
          Priority: P2
         Component: DMD
        AssignedTo: nobody@puremagic.com
        ReportedBy: wallbraker@gmail.com


--- Comment #0 from Jakob Bornecrantz <wallbraker@gmail.com> 2011-12-16 11:16:28 PST ---
In the new 1.072 release the file src/phobos/std/c/osx/osx.d is in the folder src/phobos/std/c/osx/mach/ folder instead of src/phobos/std/c/osx/. This breaks builds using various bits from phobos (std.c.posix.posix, std.socket, etc...). Move the file to the correct folder fixes the build.

Cheers, Jakob.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
December 16, 2011
http://d.puremagic.com/issues/show_bug.cgi?id=7119


Walter Bright <bugzilla@digitalmars.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|NEW                         |RESOLVED
                 CC|                            |bugzilla@digitalmars.com
         Resolution|                            |FIXED


--- Comment #1 from Walter Bright <bugzilla@digitalmars.com> 2011-12-16 15:21:06 PST ---
I corrected and uploaded the zip file.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
December 17, 2011
http://d.puremagic.com/issues/show_bug.cgi?id=7119


Jakob Bornecrantz <wallbraker@gmail.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|RESOLVED                    |CLOSED


--- Comment #2 from Jakob Bornecrantz <wallbraker@gmail.com> 2011-12-16 16:18:39 PST ---
Confirmed fixed, thanks for resolving this so fast.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
January 26, 2013
http://d.puremagic.com/issues/show_bug.cgi?id=7119


Andrei Alexandrescu <andrei@erdani.com> changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
             Status|CLOSED                      |RESOLVED
                 CC|                            |andrei@erdani.com


-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Top | Discussion index | About this forum | D home