View mode: basic / threaded / horizontal-split · Log in · Help
January 13, 2013
[Issue 9307] New: escapeShellCommand returns empty string
http://d.puremagic.com/issues/show_bug.cgi?id=9307

          Summary: escapeShellCommand returns empty string
          Product: D
          Version: D2
         Platform: x86_64
       OS/Version: Mac OS X
           Status: NEW
         Severity: normal
         Priority: P2
        Component: Phobos
       AssignedTo: nobody@puremagic.com
       ReportedBy: londey@gmail.com


--- Comment #0 from Nicholas Londey <londey@gmail.com> 2013-01-12 16:45:38 PST ---
Created an attachment (id=1179)
Example program

std.process.escapeShellCommand returns an empty string in DMD 2.61 in code that
previously worked for 2.60.

In the attached program the assert fails using DMD64 2.61 on OSX.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
January 13, 2013
[Issue 9307] escapeShellCommand returns empty string
http://d.puremagic.com/issues/show_bug.cgi?id=9307


Andrej Mitrovic <andrej.mitrovich@gmail.com> changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
                CC|                            |andrej.mitrovich@gmail.com


--- Comment #1 from Andrej Mitrovic <andrej.mitrovich@gmail.com> 2013-01-12 17:06:41 PST ---
Also reproducible on win32. I'm looking at the diff of std.process between
2.060 and 2.061, and nothing's really changed in the function implementation
apart from a single line in escapePosixArgumentImpl which has no effect on the
results on win32, so it must be some dependency function which changed
semantics.

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
January 13, 2013
[Issue 9307] escapeShellCommand returns empty string
http://d.puremagic.com/issues/show_bug.cgi?id=9307



--- Comment #2 from Andrej Mitrovic <andrej.mitrovich@gmail.com> 2013-01-12 17:10:45 PST ---
Obviously the unitttests are not run at all for this function, because
-version=unittest_burnin is never set in Phobos. Considering this uses some odd
internal "pure" allocator this might even be a result of a compiler bug. I'm
investigating though..

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
January 13, 2013
[Issue 9307] escapeShellCommand returns empty string
http://d.puremagic.com/issues/show_bug.cgi?id=9307


Andrej Mitrovic <andrej.mitrovich@gmail.com> changed:

          What    |Removed                     |Added
----------------------------------------------------------------------------
            Status|NEW                         |RESOLVED
        Resolution|                            |DUPLICATE


--- Comment #3 from Andrej Mitrovic <andrej.mitrovich@gmail.com> 2013-01-12 17:30:20 PST ---
Caused by compiler regression in 2.061, see Issue 9309.

*** This issue has been marked as a duplicate of issue 9309 ***

-- 
Configure issuemail: http://d.puremagic.com/issues/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
Top | Discussion index | About this forum | D home