View mode: basic / threaded / horizontal-split · Log in · Help
June 17, 2008
Re: Problem with Tangobos
Bill Baxter:
> Try changing the rebuild setup to compile all-at-once instead of 
> one-at-a-time.

Please, can you give me a hint regarding how to do this, or a page/doc/URL that explains how to do it? I am not able to find any documentation or any command line option regarding this (and I am not even able to find the rebuilt setup file, maybe I have to create it, but I don't know where to create it).

Bye and sorry being ignorant,
bearophile
June 17, 2008
Re: Problem with Tangobos
bearophile wrote:
> Bill Baxter:
>> Try changing the rebuild setup to compile all-at-once instead of 
>> one-at-a-time.
> 
> Please, can you give me a hint regarding how to do this, or a page/doc/URL that explains how to do it? I am not able to find any documentation or any command line option regarding this (and I am not even able to find the rebuilt setup file, maybe I have to create it, but I don't know where to create it).
> 
> Bye and sorry being ignorant,
> bearophile

In your dsss\etc\rebuild\ directory find the profile file that 
corresponds to the version of D that you're using.  Find the lines that 
say "oneatatime=yes" and change them to "oneatatime=no".

There are some possible side effects.  Namely, a different set of linker 
errors.

--bb
Top | Discussion index | About this forum | D home