View mode: basic / threaded / horizontal-split · Log in · Help
August 02, 2008
Only work from command line
Hi i've got a strange problem where i can compile the hello world example like on here: http://www.dsource.org/projects/dwt/wiki/Installation but if i try to run the main.exe that it creates nothing happens. If i type main in a command prompt while in same directory it works perfectly fine though. im using the code and dsss.conf exactly the same as that link.
August 02, 2008
Re: Only work from command line
tim m schrieb:
> Hi i've got a strange problem where i can compile the hello world
> example like on here:
> http://www.dsource.org/projects/dwt/wiki/Installation but if i try to
> run the main.exe that it creates nothing happens. If i type main in a
> command prompt while in same directory it works perfectly fine
> though. im using the code and dsss.conf exactly the same as that
> link.

http://www.digitalmars.com/webnews/newsgroups.php?art_group=digitalmars.D.dwt&article_id=1425

Perhaps this works here also. Then i should change the wiki page.
August 02, 2008
Re: Only work from command line
Frank Benoit Wrote:

> tim m schrieb:
> > Hi i've got a strange problem where i can compile the hello world
> > example like on here:
> > http://www.dsource.org/projects/dwt/wiki/Installation but if i try to
> > run the main.exe that it creates nothing happens. If i type main in a
> > command prompt while in same directory it works perfectly fine
> > though. im using the code and dsss.conf exactly the same as that
> > link.
> 
> http://www.digitalmars.com/webnews/newsgroups.php?art_group=digitalmars.D.dwt&article_id=1425
> 
> Perhaps this works here also. Then i should change the wiki page.

Thanks that worked great!
I added a line to my dsss.conf and copied dwt.res into same folder then rebuilt. My new dsss.conf looks like this now.

[main.d]
buildflags+=-L/SUBSYSTEM:windows:5
buildflags+=-L/rc:dwt
Top | Discussion index | About this forum | D home