View mode: basic / threaded / horizontal-split · Log in · Help
October 28, 2009
Re: Mini proposal: rename float.min to float.min_normal
Don Wrote:

> Don wrote:
> > This is another small imperfection we should get rid of.
> > The floating point types have a property called ".min", but unlike the 
> > integer ".min", it's not the minimum!
> 
> > This misnaming is bad because (a) it causes confusion; and (b) it 
> > interfere with generic code, requiring special cases.
> > We should rename this while we have the chance. I don't think we should 
> > depart too far from the C/C++ name, but anything other than ".min" will 
> > work. I propose:
> > 
> > real.min ----> real.min_normal
> > If there is no objection to this, I will create a patch. It's very simple.
> 
> Patch is in bugzilla 3446. It took about 2 minutes to do.

You're missing documentation updates.
Next ›   Last »
1 2
Top | Discussion index | About this forum | D home