Thread overview
Text editor with autocompletion + linting + formatting
Jul 26
aedt
July 26
I'm guessing VS Code has the most decent support for D. It's a shame I can no longer put up with VS Code. VS Code has been flickering on HDPi since ages and the issue is in stalemate[1]. What text editor do you guys use that has linting, autocompletion and dfmt support?


[1] https://github.com/Microsoft/vscode/issues/25934
No, `"editor.disableTranslate3d": true` does not do any good. And Atom doesn't have this bug.

July 26
On 26/07/2018 1:06 PM, aedt wrote:
> I'm guessing VS Code has the most decent support for D.

*no*

VisualD has been around for over 8 years. It's just Windows only.

Mono-D and VisualD used the same engine, Mono-D had the best experience over all at the time however and yes I still use it.

July 26
On Thursday, 26 July 2018 at 01:06:32 UTC, aedt wrote:
> I'm guessing VS Code has the most decent support for D. It's a shame I can no longer put up with VS Code. VS Code has been flickering on HDPi since ages and the issue is in stalemate[1]. What text editor do you guys use that has linting, autocompletion and dfmt support?

I have published an Atom package for D, but my language server behind it does crash often, so the experience is not really optimal.
https://atom.io/packages/ide-dlang
July 26
On Thursday, 26 July 2018 at 01:06:32 UTC, aedt wrote:
> I'm guessing VS Code has the most decent support for D. It's a shame I can no longer put up with VS Code.

Well, the thing is that in theory, you can use the 'serve-d' project (https://github.com/Pure-D/serve-d) with almost every editor that supports the LSP (Language Server Protocol) since 'serve-d' is a LSP implementation.

So you could try to connect it to Vim for instance, using the LSP client plugins like this one: https://github.com/autozimu/LanguageClient-neovim

However, in practice it's not guaranteed that you won't get any issues connecting those things together.

But you can try.
July 26
On Thursday, 26 July 2018 at 01:06:32 UTC, aedt wrote:
> I'm guessing VS Code has the most decent support for D. It's a shame I can no longer put up with VS Code. VS Code has been flickering on HDPi since ages and the issue is in stalemate[1]. What text editor do you guys use that has linting, autocompletion and dfmt support?
>
>
> [1] https://github.com/Microsoft/vscode/issues/25934
> No, `"editor.disableTranslate3d": true` does not do any good. And Atom doesn't have this bug.

There is also the D Language plugin for IntelliJ IDEA. The features you requested are available. More IDEs you can find here
https://wiki.dlang.org/IDEs

Kind regards
Andre