View mode: basic / threaded / horizontal-split · Log in · Help
May 05, 2010
BITPROX Development Environment 1.0 Beta 1
Hello,

I would like to introduce the first beta release of the IDE for D:
BITPROX Development Environment 1.0 Beta 1

You can download the trial beta version from the address:
http://bitprox.com/en/download/bde1.0beta1.zip

Please, try it.
I would like to listen for your opinion.
Thank you.

Alex Makhotin,
the founder of BITPROX,
http://bitprox.com
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
On 05/05/10 20:08, Alex Makhotin wrote:
> Hello,
>
> I would like to introduce the first beta release of the IDE for D:
> BITPROX Development Environment 1.0 Beta 1
>
> You can download the trial beta version from the address:
> http://bitprox.com/en/download/bde1.0beta1.zip
>
> Please, try it.
> I would like to listen for your opinion.
> Thank you.
>
> Alex Makhotin,
> the founder of BITPROX,
> http://bitprox.com
>

At first I was going to reply with an uncharitable "oh goody, another 
Windows D IDE.". It was only upon closer inspection that I was made 
aware that it was in fact for Linux!

I'm too tired at the moment to really put it through its paces, so I'll 
just say it looks promising, if unpolished in places. Keep up the good work!
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
I get an error when I try running ./bde

./bde: error while loading shared libraries: 
libwx_gtk2ud_richtext-2.8.so.0: cannot open shared object file: No such 
file or directory

These files exist in the current directory:
ls -l libwx_gtk2ud_richtext-2.8.so.0
lrwxrwxrwx 1 awhite awhite 34 2010-05-05 12:47 
libwx_gtk2ud_richtext-2.8.so.0 -> libwx_gtk2ud_richtext-2.8.so.0.6.0

So I'm not sure what's going on. I'm running Ubuntu 9.10 linux kernel 
2.6.31-21-generic
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
Arlo White wrote:
> I get an error when I try running ./bde
> 
> ../bde: error while loading shared libraries: 
> libwx_gtk2ud_richtext-2.8.so.0: cannot open shared object file: No such 
> file or directory
> 
> These files exist in the current directory:
> ls -l libwx_gtk2ud_richtext-2.8.so.0
> lrwxrwxrwx 1 awhite awhite 34 2010-05-05 12:47 
> libwx_gtk2ud_richtext-2.8.so.0 -> libwx_gtk2ud_richtext-2.8.so.0.6.0
> 
> So I'm not sure what's going on. I'm running Ubuntu 9.10 linux kernel 
> 2.6.31-21-generic

Hi,

Did you read the readme_en.txt?
You have to add the directory where you've unpacked the zip archive to 
the LD_LIBRARY_PATH environment variable of the OS.
It can be done with the Ubuntu without root permissions by editing the 
'.profile' file in your user's directory:

LD_LIBRARY_PATH=/home/user/bde1.0beta1:$LD_LIBRARY_PATH
export LD_LIBRARY_PATH

, where '/home/user/bde1.0beta1' is the location where you've unpacked 
the archive.

Then open the bash shell and type:

. ~/.profile
cd /home/user/bde1.0beta1
./bde

As long as you have the 32-bit support libraries you should be fine.
But to attach the DMD compiler and debugger you should read the readme 
file anyway.

I hope this help.


Alex Makhotin,
the founder of BITPROX,
http://bitprox.com
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
On 06/05/10 11:15, Alex Makhotin wrote:
> Arlo White wrote:
>> I get an error when I try running ./bde
>>
>> ../bde: error while loading shared libraries:
>> libwx_gtk2ud_richtext-2.8.so.0: cannot open shared object file: No
>> such file or directory
>>
>> These files exist in the current directory:
>> ls -l libwx_gtk2ud_richtext-2.8.so.0
>> lrwxrwxrwx 1 awhite awhite 34 2010-05-05 12:47
>> libwx_gtk2ud_richtext-2.8.so.0 -> libwx_gtk2ud_richtext-2.8.so.0.6.0
>>
>> So I'm not sure what's going on. I'm running Ubuntu 9.10 linux kernel
>> 2.6.31-21-generic
>
> Hi,
>
> Did you read the readme_en.txt?
> You have to add the directory where you've unpacked the zip archive to
> the LD_LIBRARY_PATH environment variable of the OS.
> It can be done with the Ubuntu without root permissions by editing the
> '.profile' file in your user's directory:
>
> LD_LIBRARY_PATH=/home/user/bde1.0beta1:$LD_LIBRARY_PATH
> export LD_LIBRARY_PATH
>
> , where '/home/user/bde1.0beta1' is the location where you've unpacked
> the archive.
>
> Then open the bash shell and type:
>
> . ~/.profile
> cd /home/user/bde1.0beta1
> ./bde
>
> As long as you have the 32-bit support libraries you should be fine.
> But to attach the DMD compiler and debugger you should read the readme
> file anyway.
>
> I hope this help.
>
>
> Alex Makhotin,
> the founder of BITPROX,
> http://bitprox.com

Best practice dictates that you do these things in a shell-script that 
runs the executable for the user (a-la firefox).
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
Bernard Helyer wrote:
> On 06/05/10 11:15, Alex Makhotin wrote:
>> Arlo White wrote:
>>> I get an error when I try running ./bde
>>>
>>> ../bde: error while loading shared libraries:
>>> libwx_gtk2ud_richtext-2.8.so.0: cannot open shared object file: No
>>> such file or directory
>>>
>>> These files exist in the current directory:
>>> ls -l libwx_gtk2ud_richtext-2.8.so.0
>>> lrwxrwxrwx 1 awhite awhite 34 2010-05-05 12:47
>>> libwx_gtk2ud_richtext-2.8.so.0 -> libwx_gtk2ud_richtext-2.8.so.0.6.0
>>>
>>> So I'm not sure what's going on. I'm running Ubuntu 9.10 linux kernel
>>> 2.6.31-21-generic
>>
>> Hi,
>>
>> Did you read the readme_en.txt?
>> You have to add the directory where you've unpacked the zip archive to
>> the LD_LIBRARY_PATH environment variable of the OS.
>> It can be done with the Ubuntu without root permissions by editing the
>> '.profile' file in your user's directory:
>>
>> LD_LIBRARY_PATH=/home/user/bde1.0beta1:$LD_LIBRARY_PATH
>> export LD_LIBRARY_PATH
>>
>> , where '/home/user/bde1.0beta1' is the location where you've unpacked
>> the archive.
>>
>> Then open the bash shell and type:
>>
>> . ~/.profile
>> cd /home/user/bde1.0beta1
>> ./bde
>>
>> As long as you have the 32-bit support libraries you should be fine.
>> But to attach the DMD compiler and debugger you should read the readme
>> file anyway.
>>
>> I hope this help.
>>
>>
>> Alex Makhotin,
>> the founder of BITPROX,
>> http://bitprox.com
> 
> Best practice dictates that you do these things in a shell-script that 
> runs the executable for the user (a-la firefox).

I will make this change in the next release.
Should solve the issue, thanks for suggestion.



Alex Makhotin,
the founder of BITPROX,
http://bitprox.com
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
Ok a few things...
1. put up screen shots.
1a. If the program looks nice people will be more likely to download it.
1b. I would be a quicker way of telling if the program in question is 
for windows or linux or both.
2. when releasing for linux use tar.gz or tgz. shows that in fact it is 
for linux.
3. have what platform the program is for in the description of the program.

I really don't like downloading programs that are over 10mb with out 
knowing that it looks like what features it has and especially what 
platform it is intended for.

just some thoughts. i don't have any flavor of linux installed atm but 
i'll give it a go when i get arch installed later tonight or tomorrow.

-dave

On 5/5/2010 3:08 AM, Alex Makhotin wrote:
> Hello,
>
> I would like to introduce the first beta release of the IDE for D:
> BITPROX Development Environment 1.0 Beta 1
>
> You can download the trial beta version from the address:
> http://bitprox.com/en/download/bde1.0beta1.zip
>
> Please, try it.
> I would like to listen for your opinion.
> Thank you.
>
> Alex Makhotin,
> the founder of BITPROX,
> http://bitprox.com
>
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
On 05/05/2010 03:08 AM, Alex Makhotin wrote:
> Hello,
>
> I would like to introduce the first beta release of the IDE for D:
> BITPROX Development Environment 1.0 Beta 1
>
> You can download the trial beta version from the address:
> http://bitprox.com/en/download/bde1.0beta1.zip
>
> Please, try it.
> I would like to listen for your opinion.
> Thank you.
>
> Alex Makhotin,
> the founder of BITPROX,
> http://bitprox.com
>

Well, that was a bugger to install (fedora 12 x86_64)

yum gtk2.i686

mod to /etc/ld.so.conf

# /sbin/ldconfig

And it works! (for some reason LD_LIBRARY_PATH didn't seem to have any 
effect)

Sooo, given I have a mongo project, how to proceed?

create workspace, create project, import source directory? With these 
IDEs I'm always afraid they're going to do something weird with my 
source code.. Try to build, and dmd says module x.y.z is in x/y/z.d and 
can't be read or something to that effect. All right, fine. I can work 
with that. Add source directory to import list. Ding!

Warnings!! Aaaa! Turn warnings off.

Compiling. one. file. at. a. time. Is there a way to give all the files 
to dmd at once? At the rate bitprox is going, it's going to take a 
couple of hours to compile my project..

In the compiler window, it only shows the name of the file being 
compiled. Is there an option to show the full package of the file? 
(without the package part, many of my modules share the same name)

No autoindent in editor? Oh, I get it. It just doesn't understand vim's 
indenting. Any way to format?

I like the source code coloring. It's quite pleasant compared to vim's. 
I don't think comments and string literals should share the same color, 
though.

also, you seem to be missing the /+ +/ comments

doesn't color 'invariant', does color 'string' but not 'wstring' or 
'dstring'

doesn't color #line

It'd be nice if it emboldened the escape sequences inside string 
literals, e.g. "\u0000", since I often forget how many digits need to 
follow \u vs \U, etc.

missing wysiwyg string literals, hex string literals, character literals

when I type something like

wagga w;

it says `Identifier 'wagga' is not defined`
and then it says `Wagga is used as a type` (note the capitalization 
which is going to annoy the bejeebers out of me)

Ooo.. And when you cancel build, build, it restarts the build from 
scratch. Here we go again.

Error: Cannot find GDB Debugger executable (gdb).

Don't know why. Does it not like 64bit executables?


All in all, I'd say it's a solid start. Don't know if I can tear myself 
away from vim, but it would be nice to have incremental compilation..
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
On 06/05/10 11:00, Ellery Newcomer wrote:
>
> Don't know why. Does it not like 64bit executables?

For some reason you have to manually specify the path in the settings. 
'/usr/bin', most likely.
May 05, 2010
Re: BITPROX Development Environment 1.0 Beta 1
Dave wrote:
> Ok a few things...
> 1. put up screen shots.
> 1a. If the program looks nice people will be more likely to download it.
> 1b. I would be a quicker way of telling if the program in question is 
> for windows or linux or both.
> 2. when releasing for linux use tar.gz or tgz. shows that in fact it is 
> for linux.
> 3. have what platform the program is for in the description of the program.
> 
> I really don't like downloading programs that are over 10mb with out 
> knowing that it looks like what features it has and especially what 
> platform it is intended for.
> 
> just some thoughts. i don't have any flavor of linux installed atm but 
> i'll give it a go when i get arch installed later tonight or tomorrow.
> 
> -dave
> ...
> 

Hi,

Did it.
You can view the screenshots on the page:
http://bitprox.com/en/products/bde/scr.html

I made the notice of the beta release version which is only for 
GNU/Linux only(this information was in readme file, however).
Next time will package in tar format for Linux.

Download of readme file is now accessible directly without downloading 
the full package.
http://bitprox.com/en/products/bde/readme_en.txt

Thanks for the feedback.

Alex Makhotin,
the founder of BITPROX,
http://bitprox.com
« First   ‹ Prev
1 2
Top | Discussion index | About this forum | D home