Thread overview
LDC 1.3.0-beta2
Jun 12
kinke
Jun 12
Wulfklaue
Jun 13
Oleg B
Jun 13
kinke
Jun 13
kinke
June 12
Hi everyone,

LDC 1.3.0-beta2, the LLVM-based D compiler, is available for download!
This release is based on the 2.073.2 frontend and standard library and supports LLVM 3.5-4.0.

It's been a while since beta1, so besides numerous fixes there are also new features.

Change log and downloads: https://github.com/ldc-developers/ldc/releases/tag/v1.3.0-beta2

Regards,
kinke
June 12
On Monday, 12 June 2017 at 17:49:46 UTC, kinke wrote:
> Hi everyone,
>
> LDC 1.3.0-beta2, the LLVM-based D compiler, is available for download!
> This release is based on the 2.073.2 frontend and standard library and supports LLVM 3.5-4.0.
>
> It's been a while since beta1, so besides numerous fixes there are also new features.
>
> Change log and downloads: https://github.com/ldc-developers/ldc/releases/tag/v1.3.0-beta2
>
> Regards,
> kinke

Nice job. Its good to see LLVM support progressing.
June 12
On Monday, 12 June 2017 at 17:49:46 UTC, kinke wrote:
> LDC 1.3.0-beta2, the LLVM-based D compiler, is available for download!
> This release is based on the 2.073.2 frontend and standard library and supports LLVM 3.5-4.0.

A snap package for this, using the LLVM 4.0.0 backend, is available in the 1.3/beta release channel.  New users can install this with:

    sudo snap install --classic --channel=1.3/beta ldc2

while existing users can switch to it with

    sudo snap refresh --classic --channel=1.3/beta ldc2
June 13
On Monday, 12 June 2017 at 17:49:46 UTC, kinke wrote:
> Hi everyone,
>
> LDC 1.3.0-beta2, the LLVM-based D compiler, is available for download!
> This release is based on the 2.073.2 frontend and standard library and supports LLVM 3.5-4.0.
>
> It's been a while since beta1, so besides numerous fixes there are also new features.
>
> Change log and downloads: https://github.com/ldc-developers/ldc/releases/tag/v1.3.0-beta2
>
> Regards,
> kinke

You plain build armhf version, like for 1.1.0? Or will it never happen again?
June 13
On Tuesday, 13 June 2017 at 09:27:42 UTC, Oleg B wrote:
> You plain build armhf version, like for 1.1.0? Or will it never happen again?

It will happen again I assume, but we don't have the capacity at the moment.
June 13
On Monday, 12 June 2017 at 17:49:46 UTC, kinke wrote:
> This release is based on the 2.073.2 frontend and standard library and supports LLVM 3.5-4.0.

Nice job.

I look forward to LDC using the current frontend: I had to revert my use of -dip1000 because LDC 1.3.0-beta2 complains about Phobos errors when used with that option.
June 13
On Tuesday, 13 June 2017 at 16:29:24 UTC, Luís Marques wrote:
> I look forward to LDC using the current frontend: I had to revert my use of -dip1000 because LDC 1.3.0-beta2 complains about Phobos errors when used with that option.

2.074.1 integration is as good as complete; you may build https://github.com/ldc-developers/ldc/pull/2076 if you can't wait. ;)