View mode: basic / threaded / horizontal-split · Log in · Help
October 14, 2011
dmd.conf change for Ubuntu 11.10
Changes to gcc or ld in Ubuntu 11.10 require a small addition to prevent 
linker errors referencing librt. "-L-lphobos2" needs to be added to DFLAGS 
before "-L-lrt". I spent a long time trying to figure the problem out before 
I realized that gcc was tacking on a -lphobos2 to the END of the command 
(after the -lrt flag).

This page: https://wiki.ubuntu.com/NattyNarwhal/ToolchainTransition may 
explain the behavior, I'm not sure.
October 15, 2011
Re: dmd.conf change for Ubuntu 11.10
On Fri, 14 Oct 2011 13:05:04 -0700, Justin Whear wrote:

> Changes to gcc or ld in Ubuntu 11.10 require a small addition to prevent
> linker errors referencing librt. "-L-lphobos2" needs to be added to
> DFLAGS before "-L-lrt". I spent a long time trying to figure the problem
> out before I realized that gcc was tacking on a -lphobos2 to the END of
> the command (after the -lrt flag).
> 
> This page: https://wiki.ubuntu.com/NattyNarwhal/ToolchainTransition may
> explain the behavior, I'm not sure.

The relevant text:

Ubuntu is changing the way it handles shared library linking for the 
Natty release. (Similar changes are being discussed for Debian.)
...
The --as-needed [on by default] option also makes the linker sensitive to 
the ordering of libraries on the command-line. You may need to move some 
libraries later in the command-line, so they come after other libraries 
or files that require symbols from them.
October 15, 2011
Re: dmd.conf change for Ubuntu 11.10
Am 14.10.2011, 22:05 Uhr, schrieb Justin Whear  
<justin@economicmodeling.com>:

> Changes to gcc or ld in Ubuntu 11.10 require a small addition to prevent
> linker errors referencing librt. "-L-lphobos2" needs to be added to  
> DFLAGS
> before "-L-lrt". I spent a long time trying to figure the problem out  
> before
> I realized that gcc was tacking on a -lphobos2 to the END of the command
> (after the -lrt flag).
>
> This page: https://wiki.ubuntu.com/NattyNarwhal/ToolchainTransition may
> explain the behavior, I'm not sure.

That page is about Natty though, i.e. 11.04.
Strangely I used 11.04 for quite some time and didn't experience any  
problems.
October 17, 2011
Re: dmd.conf change for Ubuntu 11.10
On 10/15/2011 08:03 AM, Trass3r wrote:
> Am 14.10.2011, 22:05 Uhr, schrieb Justin Whear
> <justin@economicmodeling.com>:
>
>> Changes to gcc or ld in Ubuntu 11.10 require a small addition to prevent
>> linker errors referencing librt. "-L-lphobos2" needs to be added to
>> DFLAGS
>> before "-L-lrt". I spent a long time trying to figure the problem out
>> before
>> I realized that gcc was tacking on a -lphobos2 to the END of the command
>> (after the -lrt flag).
>>
>> This page: https://wiki.ubuntu.com/NattyNarwhal/ToolchainTransition may
>> explain the behavior, I'm not sure.
>
> That page is about Natty though, i.e. 11.04.
> Strangely I used 11.04 for quite some time and didn't experience any
> problems.
Yeah, I noticed that, too - I'm on 11.04 again, and I can compile fine 
now. No page like that exists for Oneiric that I can find, so it's 
definitely worth more looking in to.
October 17, 2011
Re: dmd.conf change for Ubuntu 11.10
On Mon, 17 Oct 2011 01:56:47 -0400, Matt Soucy <msoucy@csh.rit.edu> wrote:

> On 10/15/2011 08:03 AM, Trass3r wrote:
>> Am 14.10.2011, 22:05 Uhr, schrieb Justin Whear
>> <justin@economicmodeling.com>:
>>
>>> Changes to gcc or ld in Ubuntu 11.10 require a small addition to  
>>> prevent
>>> linker errors referencing librt. "-L-lphobos2" needs to be added to
>>> DFLAGS
>>> before "-L-lrt". I spent a long time trying to figure the problem out
>>> before
>>> I realized that gcc was tacking on a -lphobos2 to the END of the  
>>> command
>>> (after the -lrt flag).
>>>
>>> This page: https://wiki.ubuntu.com/NattyNarwhal/ToolchainTransition may
>>> explain the behavior, I'm not sure.
>>
>> That page is about Natty though, i.e. 11.04.
>> Strangely I used 11.04 for quite some time and didn't experience any
>> problems.
> Yeah, I noticed that, too - I'm on 11.04 again, and I can compile fine  
> now. No page like that exists for Oneiric that I can find, so it's  
> definitely worth more looking in to.

http://d.puremagic.com/issues/show_bug.cgi?id=6822

Just ran into this today after upgrading last week.

-Steve
October 19, 2011
Re: dmd.conf change for Ubuntu 11.10
On Mon, 17 Oct 2011 08:43:46 -0400, Steven Schveighoffer  
<schveiguy@yahoo.com> wrote:

> On Mon, 17 Oct 2011 01:56:47 -0400, Matt Soucy <msoucy@csh.rit.edu>  
> wrote:
>
>> On 10/15/2011 08:03 AM, Trass3r wrote:
>>> Am 14.10.2011, 22:05 Uhr, schrieb Justin Whear
>>> <justin@economicmodeling.com>:
>>>
>>>> Changes to gcc or ld in Ubuntu 11.10 require a small addition to  
>>>> prevent
>>>> linker errors referencing librt. "-L-lphobos2" needs to be added to
>>>> DFLAGS
>>>> before "-L-lrt". I spent a long time trying to figure the problem out
>>>> before
>>>> I realized that gcc was tacking on a -lphobos2 to the END of the  
>>>> command
>>>> (after the -lrt flag).
>>>>
>>>> This page: https://wiki.ubuntu.com/NattyNarwhal/ToolchainTransition  
>>>> may
>>>> explain the behavior, I'm not sure.
>>>
>>> That page is about Natty though, i.e. 11.04.
>>> Strangely I used 11.04 for quite some time and didn't experience any
>>> problems.
>> Yeah, I noticed that, too - I'm on 11.04 again, and I can compile fine  
>> now. No page like that exists for Oneiric that I can find, so it's  
>> definitely worth more looking in to.
>
> http://d.puremagic.com/issues/show_bug.cgi?id=6822
>
> Just ran into this today after upgrading last week.

Fix just committed, yay! :)

-Steve
Top | Discussion index | About this forum | D home