View mode: basic / threaded / horizontal-split · Log in · Help
August 20, 2012
Unexpected OPTLINK termination
I just ran into (I think) this bug 
http://d.puremagic.com/issues/show_bug.cgi?id=8377 using dmd 
2.060. Seeing that there was a fix in git, I cloned the latest 
git dmd, built, and dropped the .exe into my existing dmd 2.060 
installation directory.

I still get this unexpected optlink termination (although the 
location of the error is different - EIP=00424D76 - don't know if 
that is significant or not).

Thing is, I only hit the error when I compile a Debug target. In 
release mode there is no error.

I don't think I can narrow down this problem easily, I suspect 
the problem is in a 11k lines module of template heavy code 
generated by Pegged. I am just wondering if anyone who saw this 
problem pre the git commit also has trouble with debug builds, or 
if this is a different bug.

Cheers
cal
August 20, 2012
Re: Unexpected OPTLINK termination
On Mon, Aug 20, 2012 at 7:33 AM, cal <callumenator@gmail.com> wrote:

> I don't think I can narrow down this problem easily, I suspect the problem
> is in a 11k lines module of template heavy code generated by Pegged. I am
> just wondering if anyone who saw this problem pre the git commit also has
> trouble with debug builds, or if this is a different bug.

I also had lots of trouble with Pegged and optlink since 2.060. Are
you using rdmd? Because I have no linking problems with dmd, only
rdmd, strangely enough. Maybe it's due to rdmd reusing cached
information that should be updated more aggressively.
August 20, 2012
Re: Unexpected OPTLINK termination
On Monday, 20 August 2012 at 13:50:27 UTC, Philippe Sigaud wrote:
> On Mon, Aug 20, 2012 at 7:33 AM, cal <callumenator@gmail.com> 
> wrote:
>
>> I don't think I can narrow down this problem easily, I suspect 
>> the problem
>> is in a 11k lines module of template heavy code generated by 
>> Pegged. I am
>> just wondering if anyone who saw this problem pre the git 
>> commit also has
>> trouble with debug builds, or if this is a different bug.
>
> I also had lots of trouble with Pegged and optlink since 2.060. 
> Are
> you using rdmd? Because I have no linking problems with dmd, 
> only
> rdmd, strangely enough. Maybe it's due to rdmd reusing cached
> information that should be updated more aggressively.

I tried both dmd and rdmd, both give the same result, optlink 
crash in debug build. I'm going to give dustmite a go, see if I 
can reduce it at all.
Top | Discussion index | About this forum | D home