View mode: basic / threaded / horizontal-split · Log in · Help
December 03, 2012
GtkD 2.1 released, GTK+ with D.
GtkD is a D binding and OO wrapper of Gtk+ and is released on the LGPL
license.

New in this release:
* GtkD wraps the latest version of GTK, version 3.6.
* Some bug fixes to support 64 bits windows.
* Compiles with DMD 2.061.
* pkg-config files.

For both the Gtk+ 3.x and the Gtk 2.x branches on linux the library file 
names are post fixed with the major version number so they can be 
installed side by side.

GtkD 2.1 and 1.7 are now available on GitHub:
https://github.com/gtkd-developers/GtkD/downloads

-- 
Mike Wey
December 04, 2012
Re: GtkD 2.1 released, GTK+ with D.
On Monday, 3 December 2012 at 22:25:21 UTC, Mike Wey wrote:
> GtkD is a D binding and OO wrapper of Gtk+ and is released on 
> the LGPL license.

> New in this release:
> * GtkD wraps the latest version of GTK, version 3.6.
> * Some bug fixes to support 64 bits windows.
> * Compiles with DMD 2.061.
> * pkg-config files.

Awesome, I'm using GtkD a lot on my Editor!
December 04, 2012
Re: GtkD 2.1 released, GTK+ with D.
Al 03/12/12 23:26, En/na Mike Wey ha escrit:
> GtkD is a D binding and OO wrapper of Gtk+ and is released on the LGPL
> license.
> 
> New in this release:
> * GtkD wraps the latest version of GTK, version 3.6.
> * Some bug fixes to support 64 bits windows.
> * Compiles with DMD 2.061.
> * pkg-config files.
> 
> For both the Gtk+ 3.x and the Gtk 2.x branches on linux the library file names are post fixed with the major version number so they can be installed side by side.
> 
> GtkD 2.1 and 1.7 are now available on GitHub:
> https://github.com/gtkd-developers/GtkD/downloads
> 

Congratulations for this new releases Mike!

Great work!
-- 
Jordi Sayol
December 05, 2012
Re: GtkD 2.1 released, GTK+ with D.
On 04/12/12 08:56, Mike Wey wrote:
> GtkD is a D binding and OO wrapper of Gtk+ and is released on the LGPL
> license.
>
> New in this release:
> * GtkD wraps the latest version of GTK, version 3.6.
> * Some bug fixes to support 64 bits windows.
> * Compiles with DMD 2.061.
> * pkg-config files.
>
> For both the Gtk+ 3.x and the Gtk 2.x branches on linux the library file
> names are post fixed with the major version number so they can be
> installed side by side.
>
> GtkD 2.1 and 1.7 are now available on GitHub:
> https://github.com/gtkd-developers/GtkD/downloads
>

Thanks Mike. Appreciate all your good work!
December 05, 2012
Re: GtkD 2.1 released, GTK+ with D.
On 04/12/12 08:56, Mike Wey wrote:
> GtkD is a D binding and OO wrapper of Gtk+ and is released on the LGPL
> license.
>
> New in this release:
> * GtkD wraps the latest version of GTK, version 3.6.
> * Some bug fixes to support 64 bits windows.
> * Compiles with DMD 2.061.
> * pkg-config files.
>
> For both the Gtk+ 3.x and the Gtk 2.x branches on linux the library file
> names are post fixed with the major version number so they can be
> installed side by side.
>
> GtkD 2.1 and 1.7 are now available on GitHub:
> https://github.com/gtkd-developers/GtkD/downloads
>

Thanks Mike. Appreciate all your good work!
January 18, 2013
Re: GtkD 2.1 released, GTK+ with D.
> * Compiles with DMD 2.061.

unfortunately, it does not for me:

c:\gtkD\build>bud @gtkD.brf
..\src\glib\Spawn.d(244): Error: core.stdc.stdio.fdopen at c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
..\src\glib\Spawn.d(245): Error: core.stdc.stdio.fdopen at c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
..\src\glib\Spawn.d(246): Error: core.stdc.stdio.fdopen at c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)

(dmd 2.061/win32, gtkd 2.1)
January 18, 2013
Re: GtkD 2.1 released, GTK+ with D.
On 01/18/2013 01:53 AM, captaindet wrote:
>> * Compiles with DMD 2.061.
>
> unfortunately, it does not for me:
>
> c:\gtkD\build>bud @gtkD.brf
> ..\src\glib\Spawn.d(244): Error: core.stdc.stdio.fdopen at
> c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with
> gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
> ..\src\glib\Spawn.d(245): Error: core.stdc.stdio.fdopen at
> c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with
> gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
> ..\src\glib\Spawn.d(246): Error: core.stdc.stdio.fdopen at
> c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with
> gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
>
> (dmd 2.061/win32, gtkd 2.1)

fdopen was recently added to druntime for win32, should be fixed now in git.

-- 
Mike Wey
January 18, 2013
Re: GtkD 2.1 released, GTK+ with D.
On 2013-01-18 12:36, Mike Wey wrote:
> On 01/18/2013 01:53 AM, captaindet wrote:
>>> * Compiles with DMD 2.061.
>>
>> unfortunately, it does not for me:
>>
>> c:\gtkD\build>bud @gtkD.brf
>> ..\src\glib\Spawn.d(244): Error: core.stdc.stdio.fdopen at
>> c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with
>> gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
>> ..\src\glib\Spawn.d(245): Error: core.stdc.stdio.fdopen at
>> c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with
>> gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
>> ..\src\glib\Spawn.d(246): Error: core.stdc.stdio.fdopen at
>> c:\D\DMD2\src\druntime\import\core\stdc\stdio.d(758) conflicts with
>> gtkc.glibtypes.fdopen at ..\src\gtkc\glibtypes.d(114)
>>
>> (dmd 2.061/win32, gtkd 2.1)
>
> fdopen was recently added to druntime for win32, should be fixed now in git.
>

the lib compiles now. thanks!
Top | Discussion index | About this forum | D home