Thread overview
Get this error running the D blog about containerizing D in Docker
March 26
https://dlang.org/blog/2019/03/14/containerize-your-d-server-application/

I'm following the excellent blog posting by Mr. Nacke, but I keep getting the following
error when I attempt to compile hellorest with dub.  Since everything is pretty much on
autopilot, Everything seems to have worked beautifully up to this step.


generic@generic-M93p:~/vibed-docker$ dub --build=release --compiler=ldc2 --verbose

Using dub registry url 'https://code.dlang.org/'
Refreshing local packages (refresh existing: true)...
Looking for local package map at /var/lib/dub/packages/local-packages.json
Looking for local package map at /home/generic/.dub/packages/local-packages.json
Determined package version using GIT: hellorest ~master
Refreshing local packages (refresh existing: false)...
Looking for local package map at /var/lib/dub/packages/local-packages.json
Looking for local package map at /home/generic/.dub/packages/local-packages.json
  Found dependency vibe-d 0.8.5-rc.1
    Found dependency vibe-d:redis 0.8.5-rc.1
      Found dependency vibe-d:http 0.8.5-rc.1
    o   o   o
Search for versions of openssl (1 package suppliers)
Return for openssl: [2.0.0+1.1.0h, 1.1.6+1.0.1g, 1.1.5+1.0.1g, 1.1.4+1.0.1g, 1.1.3+1.0.1g, 1.1.2+1.0.1g, 1.1.1+1.0.1g, 1.1.0+1.0.1g, 1.0.0+1.0.0e, ~master]
Search for versions of botan (1 package suppliers)
Ignoring version specification (>=0.0.0) for path based dependency ../memutils
Return for botan: [1.12.10, 1.12.9, 1.12.8, 1.12.7, 1.12.6, 1.12.5, 1.12.4, 1.12.3, 1.12.2, 1.12.1, 1.12.0, 1.11.14, 1.11.13, 1.11.12, 1.11.11, 1.11.10, ~master, ~merge-new-algos, ~ldc-compat, ~fix-tls]
Search for versions of botan-math (1 package suppliers)
Return for botan-math: [1.0.3, 1.0.2, 1.0.1, 1.0.0, ~master]
Sub package botan:base doesn't exist in botan 1.12.10.
    o   o   o
Sub package botan:base doesn't exist in botan 1.11.10.
Sub package botan:base doesn't exist in botan ~master.
Sub package botan:base doesn't exist in botan ~merge-new-algos.
Sub package botan:base doesn't exist in botan ~ldc-compat.
Sub package botan:base doesn't exist in botan ~fix-tls.
Sub package botan:compression doesn't exist in botan 1.12.10.
    o   o   o
Sub package botan:compression doesn't exist in botan 1.11.10.
Sub package botan:compression doesn't exist in botan ~master.
Sub package botan:compression doesn't exist in botan ~merge-new-algos.
Sub package botan:compression doesn't exist in botan ~ldc-compat.
Sub package botan:compression doesn't exist in botan ~fix-tls.
Sub package botan:tls doesn't exist in botan 1.12.10.
    o   o   o
Sub package botan:tls doesn't exist in botan 1.11.10.
Sub package botan:tls doesn't exist in botan ~master.
Sub package botan:tls doesn't exist in botan ~merge-new-algos.
Sub package botan:tls doesn't exist in botan ~ldc-compat.
Sub package botan:tls doesn't exist in botan ~fix-tls.
Sub package botan:passhash doesn't exist in botan 1.12.10.
    o   o   o
Sub package botan:passhash doesn't exist in botan 1.11.10.
Sub package botan:passhash doesn't exist in botan ~master.
Sub package botan:passhash doesn't exist in botan ~merge-new-algos.
Sub package botan:passhash doesn't exist in botan ~ldc-compat.
Sub package botan:passhash doesn't exist in botan ~fix-tls.
Failed to load path based dependency memutils: No package file found in ../memutils/, expected one of dub.json/dub.sdl/package.json
Search for versions of mir-linux-kernel (1 package suppliers)
Return for mir-linux-kernel: [1.0.1, 1.0.0, 1.0.0-alpha2, 1.0.0-alpha1, ~master]
Search for versions of diet-ng (1 package suppliers)
Return for diet-ng: [1.5.0, 1.4.5, 1.4.4, 1.4.3, 1.4.2, 1.4.1, 1.4.0, 1.3.0, 1.2.1, 1.2.0, 1.1.4, 1.1.3, 1.1.2, 1.1.1, 1.1.0, 1.0.0, 0.3.0, 0.2.1, 0.2.0, 0.1.0, 1.0.0-beta.3, 1.0.0-beta.2, 1.0.0-beta.1, 1.0.0-alpha.2, 1.0.0-alpha.1, ~master, ~dmd_segfault]
The dependency resolution process is taking too long. The dependency graph is likely hitting a pathological case in the resolution algorithm. Please file a bug report at https://github.com/dlang/dub/issues and mention the package recipe that reproduces this error.

March 26
On Tuesday, 26 March 2019 at 17:36:15 UTC, WhatMeWorry wrote:
> https://dlang.org/blog/2019/03/14/containerize-your-d-server-application/
>
> I'm following the excellent blog posting by Mr. Nacke, but I keep getting the following
> error when I attempt to compile hellorest with dub.  Since everything is pretty much on
> autopilot, Everything seems to have worked beautifully up to this step.
>
> [...]

This error should not occur in recent versions of dub. Which dub version do you have (dub --version)?

Kind regards
Andre
March 26
On Tuesday, 26 March 2019 at 21:20:06 UTC, Andre Pany wrote:
> On Tuesday, 26 March 2019 at 17:36:15 UTC, WhatMeWorry wrote:
>> https://dlang.org/blog/2019/03/14/containerize-your-d-server-application/
>>
>> I'm following the excellent blog posting by Mr. Nacke, but I keep getting the following
>> error when I attempt to compile hellorest with dub.  Since everything is pretty much on
>> autopilot, Everything seems to have worked beautifully up to this step.
>>
>> [...]
>
> This error should not occur in recent versions of dub. Which dub version do you have (dub --version)?
>
> Kind regards
> Andre

Thanks,

I'm running Ubuntu 18.0. When I do a

sudo apt-get install dub
Reading package lists... Done
Building dependency tree
Reading state information... Done
dub is already the newest version (1.8.0-2).
0 upgraded, 0 newly installed, 0 to remove and 151 not upgraded.


but dub list returns 1.14.0

  dub 1.14.0: /home/generic/.dub/packages/dub-1.14.0/dub/

Do I have two versions of dub?  1.8.0-2 and 1.14.0?

Get the same error.


March 27
On Tuesday, 26 March 2019 at 21:58:49 UTC, WhatMeWorry wrote:
> On Tuesday, 26 March 2019 at 21:20:06 UTC, Andre Pany wrote:
>> On Tuesday, 26 March 2019 at 17:36:15 UTC, WhatMeWorry wrote:
>>> [...]
>>
>> This error should not occur in recent versions of dub. Which dub version do you have (dub --version)?
>>
>> Kind regards
>> Andre
>
> Thanks,
>
> I'm running Ubuntu 18.0. When I do a
>
> sudo apt-get install dub
> Reading package lists... Done
> Building dependency tree
> Reading state information... Done
> dub is already the newest version (1.8.0-2).
> 0 upgraded, 0 newly installed, 0 to remove and 151 not upgraded.
>
>
> but dub list returns 1.14.0
>
>   dub 1.14.0: /home/generic/.dub/packages/dub-1.14.0/dub/
>
> Do I have two versions of dub?  1.8.0-2 and 1.14.0?
>
> Get the same error.

The old dub version is causing the issue. Use the install script from https://dlang.org/download.html to install a recent ldc / dmd.

Kind regards
Andre