View mode: basic / threaded / horizontal-split · Log in · Help
November 02, 2010
Dwt2 build snippet10 link error
I am newbie of D language.
I use D v1.0.65 and tango 1.0 (lastest truck)
When i run "rake base swt" everything ok but when i run
dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp
-JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
-odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe
d:\D\dwt2\Snippet10.d
(I copyed snippet10.d from it directory to d:\D\dwt2\) i have error
D:\D\dwt2>dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src
-ID:\D\dwt2\dwt2\imp
-JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
-odD:\D\
dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d
OPTLINK (R) for Win32  Release 8.00.8
Copyright (C) Digital Mars 1989-2010  All rights reserved.
http://www.digitalmars.com/ctg/optlink.html
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e
clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3
org7eclipse3swt8graphics5Color5ColorZv
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3
org7eclipse3swt8graphics5Color5ColorZv
D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
Error 42: Symbol Undefined
_D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec
lipse3swt8graphics4Path4PathZv
.....

How to fix it.
Tuan Hoang Anh
Thank in advance.
November 03, 2010
Re: Dwt2 build snippet10 link error
On 2010-11-02 19:08, tuanhoanganh wrote:
> I am newbie of D language.
> I use D v1.0.65 and tango 1.0 (lastest truck)
> When i run "rake base swt" everything ok but when i run
> dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp
> -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
> -odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe
> d:\D\dwt2\Snippet10.d
> (I copyed snippet10.d from it directory to d:\D\dwt2\) i have error
> D:\D\dwt2>dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src
> -ID:\D\dwt2\dwt2\imp
>   -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
> -odD:\D\
> dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d
> OPTLINK (R) for Win32  Release 8.00.8
> Copyright (C) Digital Mars 1989-2010  All rights reserved.
> http://www.digitalmars.com/ctg/optlink.html
> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>   Error 42: Symbol Undefined
> _D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e
> clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path
> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>   Error 42: Symbol Undefined
> _D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3
> org7eclipse3swt8graphics5Color5ColorZv
> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>   Error 42: Symbol Undefined
> _D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3
> org7eclipse3swt8graphics5Color5ColorZv
> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>   Error 42: Symbol Undefined
> _D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec
> lipse3swt8graphics4Path4PathZv
> .....
>
> How to fix it.
> Tuan Hoang Anh
> Thank in advance.

Have you linked with the base and swt libraries ?

-- 
/Jacob Carlborg
November 03, 2010
Re: Dwt2 build snippet10 link error
I have linked to all file in lib and build with no problem.
Thanks you very much.
Tuan Hoang Anh

On Wed, Nov 3, 2010 at 5:27 PM, Jacob Carlborg <doob@me.com> wrote:

> On 2010-11-02 19:08, tuanhoanganh wrote:
>
>> I am newbie of D language.
>> I use D v1.0.65 and tango 1.0 (lastest truck)
>> When i run "rake base swt" everything ok but when i run
>> dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src -ID:\D\dwt2\dwt2\imp
>> -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
>> -odD:\D\dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe
>> d:\D\dwt2\Snippet10.d
>> (I copyed snippet10.d from it directory to d:\D\dwt2\) i have error
>> D:\D\dwt2>dmd -ID:\D\dwt2\dwt2\org.eclipse.swt.snippets\src
>> -ID:\D\dwt2\dwt2\imp
>>  -JD:\D\dwt2\dwt2\org.eclipse.swt.snippets\res -JD:\D\dwt2\dwt2\res -op
>> -odD:\D\
>> dwt2\dwt2\obj -ofD:\D\dwt2\dwt2\bin\Snippet10.exe d:\D\dwt2\Snippet10.d
>> OPTLINK (R) for Win32  Release 8.00.8
>> Copyright (C) Digital Mars 1989-2010  All rights reserved.
>> http://www.digitalmars.com/ctg/optlink.html
>> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>>  Error 42: Symbol Undefined
>> _D3org7eclipse3swt8graphics4Path4Path5_ctorMFC3org7e
>> clipse3swt8graphics6Device6DeviceZC3org7eclipse3swt8graphics4Path4Path
>> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>>  Error 42: Symbol Undefined
>> _D3org7eclipse3swt8graphics2GC2GC13setBackgroundMFC3
>> org7eclipse3swt8graphics5Color5ColorZv
>> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>>  Error 42: Symbol Undefined
>> _D3org7eclipse3swt8graphics2GC2GC13setForegroundMFC3
>> org7eclipse3swt8graphics5Color5ColorZv
>> D:\D\dwt2\dwt2\obj\Snippet10.obj(Snippet10)
>>  Error 42: Symbol Undefined
>> _D3org7eclipse3swt8graphics2GC2GC8fillPathMFC3org7ec
>> lipse3swt8graphics4Path4PathZv
>> .....
>>
>> How to fix it.
>> Tuan Hoang Anh
>> Thank in advance.
>>
>
> Have you linked with the base and swt libraries ?
>
> --
> /Jacob Carlborg
>
Top | Discussion index | About this forum | D home