Thread overview
RC 2 - Visuald on VS2017
Jul 20
jj
Jul 20
jj
Jul 21
jj
Jul 22
jj
Jul 22
jj
July 20
RC2 does not work / install



  <entry>
    <record>639</record>
    <time>2017/05/15 08:41:48.229</time>
    <type>Error</type>
    <source>VisualStudio</source>
    <description>No InprocServer32 registered for package [Visual D]</description>
    <guid>{002A2DE9-8BB6-484D-987F-7E4AD4084715}</guid>
    <hr>8007007e</hr>
    <errorinfo></errorinfo>
    <path>C:\Program Files (x86)\VisualD\visuald.dll</path>
  </entry>

July 20

On 20.07.2017 16:36, jj wrote:
> 
> RC2 does not work / install
> 
> 
> 
>    <entry>
>      <record>639</record>
>      <time>2017/05/15 08:41:48.229</time>
>      <type>Error</type>
>      <source>VisualStudio</source>
>      <description>No InprocServer32 registered for package [Visual D]</description>
>      <guid>{002A2DE9-8BB6-484D-987F-7E4AD4084715}</guid>
>      <hr>8007007e</hr>
>      <errorinfo></errorinfo>
>      <path>C:\Program Files (x86)\VisualD\visuald.dll</path>
>    </entry>
> 

Could you give a bit more details? Windows/Visual Studio version, etc?

Where does this output come from? Is it from the activitylog.xml?

Maybe a bit more context can help. You can also report bugs at https://issues.dlang.org/enter_bug.cgi and attach the full log.
July 20
On Thursday, 20 July 2017 at 18:20:27 UTC, Rainer Schuetze wrote:

> Could you give a bit more details? Windows/Visual Studio version, etc?
>
> Where does this output come from? Is it from the activitylog.xml?
>
> Maybe a bit more context can help. You can also report bugs at https://issues.dlang.org/enter_bug.cgi and attach the full log.


w10,vs2017,activitylog.xml
vs2017 doesn't know about d at all, no d project possible
July 20

On 20.07.2017 20:30, jj wrote:
> On Thursday, 20 July 2017 at 18:20:27 UTC, Rainer Schuetze wrote:
> 
>> Could you give a bit more details? Windows/Visual Studio version, etc?
>>
>> Where does this output come from? Is it from the activitylog.xml?
>>
>> Maybe a bit more context can help. You can also report bugs at https://issues.dlang.org/enter_bug.cgi and attach the full log.
> 
> 
> w10,vs2017,activitylog.xml
> vs2017 doesn't know about d at all, no d project possible

The error code translates to "The specified module could not be found."

Can you verify that the visuald.dll actually exists at the given location?

There have been some recent reports that AntiVir software tends to reject dmd-built binarries. Maybe the file has been moved away?

Does rc1 still work for you?
July 21
On Thursday, 20 July 2017 at 21:19:48 UTC, Rainer Schuetze wrote:

> The error code translates to "The specified module could not be found."
>
> Can you verify that the visuald.dll actually exists at the given location?
>
> There have been some recent reports that AntiVir software tends to reject dmd-built binarries. Maybe the file has been moved away?
>
> Does rc1 still work for you?

the file exists, and turning off AntiVir does not help.

as for the previous version, i don't know, since this should have been my second attempt at D. i stopped when i had problems with with the previous version of ldc, dmd.
July 22

On 21.07.2017 08:05, jj wrote:
> On Thursday, 20 July 2017 at 21:19:48 UTC, Rainer Schuetze wrote:
> 
>> The error code translates to "The specified module could not be found."
>>
>> Can you verify that the visuald.dll actually exists at the given location?
>>
>> There have been some recent reports that AntiVir software tends to reject dmd-built binarries. Maybe the file has been moved away?
>>
>> Does rc1 still work for you?
> 
> the file exists, and turning off AntiVir does not help.
> 
> as for the previous version, i don't know, since this should have been my second attempt at D. i stopped when i had problems with with the previous version of ldc, dmd.

Last time you reported similar problems with Kaspersky complaining. Maybe it got into the way during installation.

Also, you've reported that "devenv /RootSuffix D" did the trick (this initializes a new registry hive). Not a perfect solution, but did you try it this time, too?
July 22
On Saturday, 22 July 2017 at 07:22:04 UTC, Rainer Schuetze wrote:
>

> Last time you reported similar problems with Kaspersky complaining. Maybe it got into the way during installation.

i turned it completely off during install - no change

> Also, you've reported that "devenv /RootSuffix D" did the trick (this initializes a new registry hive). Not a perfect solution, but did you try it this time, too?

fortunately that did help - but just once. i make a project (dmd,console) compile (doesn't work because dmd install doesn't set the the environment correctly).

i leave VS2017 - close. reopen VS2017 the VS-D menu is gone. can't open project because of missing template - VS2017 asks to delete my project.



July 22

On 22.07.2017 10:03, jj wrote:
> On Saturday, 22 July 2017 at 07:22:04 UTC, Rainer Schuetze wrote:
>>
> 
>> Last time you reported similar problems with Kaspersky complaining. Maybe it got into the way during installation.
> 
> i turned it completely off during install - no change
> 
>> Also, you've reported that "devenv /RootSuffix D" did the trick (this initializes a new registry hive). Not a perfect solution, but did you try it this time, too?
> 
> fortunately that did help - but just once. i make a project (dmd,console) compile (doesn't work because dmd install doesn't set the the environment correctly).
> 
> i leave VS2017 - close. reopen VS2017 the VS-D menu is gone. can't open project because of missing template - VS2017 asks to delete my project.
> 

Not sure if it's obvious, but you always have to start the IDE with "devenv /RootSuffix D" to use the new registry hive.

Some random guesses why the standard installation doesn't work for you:

- Did you change the default installation location of VS2017?

- Are you installing/running as a restricted user?
July 22
On Saturday, 22 July 2017 at 08:28:53 UTC, Rainer Schuetze wrote:
>

> Not sure if it's obvious, but you always have to start the IDE with "devenv /RootSuffix D" to use the new registry hive.

yes always to start with "devenv /RootSuffix D" in order to use it

> Some random guesses why the standard installation doesn't work for you:
>
> - Did you change the default installation location of VS2017?

no

> - Are you installing/running as a restricted user?

no admin