December 22
I can compile the derelict-fmod example with
dub.json
           ...
        "dependencies": {
        "derelict-util": ">=1.9.1"
           ...
and dub.selections.json
            ...
  	"versions": {
		"derelict-util": "2.1.0"
            ...
dub run
Fetching derelict-util 2.1.0 (getting selected version)...
Performing "debug" build using ldc2 for x86_64.
derelict-util 2.1.0: building configuration "library"...

==============================================================

In my project, I use SDL
dub.sdl
           ...
        dependency "derelict-util"  version=">=1.9.1"
           ...
dub upgrade
Upgrading project in /home/generic/Delivery/apps/06_03_09_audio
Fetching derelict-util 2.0.6 (getting selected version)...

which is a higher version but no cigar.  So I try brute force with
dub.sdl
           ...
        dependency "derelict-util"  version="==2.1.0"
           ...

but dub upgrade returns:
Upgrading project in /home/generic/Delivery/apps/06_03_09_audio
Root package 06_03_09_audio reference derelict-util 2.1.0 cannot be satisfied.

There is definitely a 2.1.0 derelict-util package with a time stamp of 2016-Sep-05

So what am I doing wrong?