Thread overview
.LIB pagesize exceeds 512
Dec 10
user
Dec 10
Mike Wey
Dec 11
user
December 10
Could someone please list some workarounds?

I am trying to compile a demo app from gtkd. I tried compiling gtkd using dub with --build=plain option and still got that error when compiling the demo app. Using the latest dmd.

Thanks in advance.
December 10
On 10-12-17 16:57, user wrote:
> Could someone please list some workarounds?
> 
> I am trying to compile a demo app from gtkd. I tried compiling gtkd using dub with --build=plain option and still got that error when compiling the demo app. Using the latest dmd.
> 
> Thanks in advance.

As far as i know the error is caused by the debug information, and using `--build=plain` for dub used to fix that, but that might have changed.

You could try building gtkD with the windows build script: `rdmd Build.d`

Or if possible build the 64bit version witch doesn't use optlink.

https://issues.dlang.org/show_bug.cgi?id=15418

-- 
Mike Wey
December 11
On Sunday, 10 December 2017 at 21:51:37 UTC, Mike Wey wrote:
> On 10-12-17 16:57, user wrote:
>> Could someone please list some workarounds?
>> 
>> I am trying to compile a demo app from gtkd. I tried compiling gtkd using dub with --build=plain option and still got that error when compiling the demo app. Using the latest dmd.
>> 
>> Thanks in advance.
>
> As far as i know the error is caused by the debug information, and using `--build=plain` for dub used to fix that, but that might have changed.
>
> You could try building gtkD with the windows build script: `rdmd Build.d`
>
> Or if possible build the 64bit version witch doesn't use optlink.
>
> https://issues.dlang.org/show_bug.cgi?id=15418

I ended up downloading LDC and it worked after downloading MS C++ build tools. But now I am get errors compiling vibe.d, I simply added vibe-d as dependency to the 'dub init'.


C:\vibe_test>dub
Performing "debug" build using ldc2 for x86.
memutils 0.4.9: target for configuration "secure" is up to date.
libasync 0.8.3: target for configuration "regular" is up to date.
vibe-d:utils 0.8.1: target for configuration "library" is up to date.
vibe-d:data 0.8.1: target for configuration "library" is up to date.
vibe-d:core 0.8.1: target for configuration "libasync" is up to date.
vibe-d:crypto 0.8.1: target for configuration "library" is up to date.
diet-ng 1.4.3: target for configuration "library" is up to date.
vibe-d:stream 0.8.1: target for configuration "library" is up to date.
vibe-d:textfilter 0.8.1: target for configuration "library" is up to date.
vibe-d:inet 0.8.1: target for configuration "library" is up to date.
vibe-d:tls 0.8.1: target for configuration "openssl-mscoff" is up to date.
vibe-d:http 0.8.1: target for configuration "library" is up to date.
vibe-d:mail 0.8.1: target for configuration "library" is up to date.
vibe-d:mongodb 0.8.1: target for configuration "library" is up to date.
vibe-d:redis 0.8.1: target for configuration "library" is up to date.
vibe-d:web 0.8.1: target for configuration "library" is up to date.
vibe-d 0.8.1: target for configuration "libasync" is up to date.
vibe_test ~master: building configuration "application"...
Warning: no Visual C++ installation detected
C:\Users\user\AppData\Roaming\dub\packages\libasync-0.8.3\libasync\ws2_32_ex.
lib : fatal error LNK1136: invalid or corrupt file
Error: C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\BIN\link.exe faile
d with status: 1136
ldc2 failed with exit code 1136.


:-(