October 20
On Monday, 12 October 2020 at 17:26:22 UTC, Iain Buclaw wrote:
> The assumption is you already know how to build gcc from here.

Building all of gcc in OS-X is rather massive. Is there a way to only build gdc? I gave "configure" the option --enable-languages=d, but gcc10 seems to build all of gcc and g++ as well.
October 20
On Tuesday, 20 October 2020 at 15:35:52 UTC, Ola Fosheim Grøstad wrote:
> On Monday, 12 October 2020 at 17:26:22 UTC, Iain Buclaw wrote:
>> The assumption is you already know how to build gcc from here.
>
> Building all of gcc in OS-X is rather massive. Is there a way to only build gdc? I gave "configure" the option --enable-languages=d, but gcc10 seems to build all of gcc and g++ as well.

Hm, I guess I have to build phobos and the runtime with gdc for OS-X as well, to get it to bootstrap.

What is the search path? "> gdc -print-search-dirs" seems to only give gcc search dirs.

I configured gcc10 with:

../configure  --prefix=some_install_dir --enable-languages=d --disable-multilib --with-sysroot=/Library/Developer/CommandLineTools/SDKs/MacOSX.sdk

October 21
On Tuesday, 20 October 2020 at 15:35:52 UTC, Ola Fosheim Grøstad wrote:

> Building all of gcc in OS-X is rather massive. Is there a way to only build gdc? I gave "configure" the option --enable-languages=d, but gcc10 seems to build all of gcc and g++ as well.

How will you compile the C code, pre-compiled GCC? I'm guessing it's best to use the same compiler.

--
/Jacob Carlborg
October 21
On Wednesday, 21 October 2020 at 11:57:33 UTC, Jacob Carlborg wrote:
> On Tuesday, 20 October 2020 at 15:35:52 UTC, Ola Fosheim Grøstad wrote:
>
>> Building all of gcc in OS-X is rather massive. Is there a way to only build gdc? I gave "configure" the option --enable-languages=d, but gcc10 seems to build all of gcc and g++ as well.
>
> How will you compile the C code, pre-compiled GCC? I'm guessing it's best to use the same compiler.

I have macports. GCC seems to have a 3 stage boostrapping process? There seems to be a flag for disabling it "-disable-bootstrap". I guess I could try that.



Next ›   Last »
1 2