January 07, 2013
Hi,

  Since I have upgraded my dmd from version 2.060 to 2.061 the cliend.d and server.d is not compiling anymore (thrift-0.9.0/tutorial/d).

  Someone with same problem?

  Best regards,

    Ivan

[irocha@irrlab d]$ pwd
/data/D/thrift-0.9.0/tutorial/d
[irocha@irrlab d]$ make
dmd -I../../lib/d/src -L-L../../lib/d -L-lthriftd server.d ../gen-d/share/SharedService.d ../gen-d/share/shared_types.d ../gen-d/tutorial/tutorial_types.d ../gen-d/tutorial/Calculator.d
../../lib/d/src/thrift/codegen/processor.d(155): Error: module thrift.codegen.processor thrift.internal.codegen.FilterMethodNames(T, MemberNames...) is private
../../lib/d/src/thrift/codegen/processor.d(317): Error: CTFE failed because of previous errors in __lambda1161
../../lib/d/src/thrift/codegen/processor.d(317): Error: argument to mixin must be a string, not ((*delegate @system string()
...
...
server.d(101): Error: template instance thrift.codegen.processor.TServiceProcessor!(Calculator) error instantiating
server.d(101): Error: TServiceProcessor!(Calculator) is used as a type
server.d(105): Error: constructor thrift.server.simple.TSimpleServer.this (TProcessor processor, TServerTransport serverTransport, TTransportFactory transportFactory, TProtocolFactory protocolFactory) is not callable using argument types (_error_,TServerSocket,TWrapperTransportFactory,TBinaryProtocolFactory)
server.d(105): Error: expected 6 function arguments, not 4
January 07, 2013
On Monday, 7 January 2013 at 12:14:17 UTC, Ivan Ribeiro wrote:
>   Since I have upgraded my dmd from version 2.060 to 2.061 the cliend.d and server.d is not compiling anymore (thrift-0.9.0/tutorial/d).
>
>   Someone with same problem?

I must admit that I didn't test the tutorial, but the test suite is passing again on trunk/Git master, which contains a fix for the issue you are hitting (really just a wrong Ā»privateĀ« qualifier, which was not checked by DMD before).

David
Top | Discussion index | About this forum | D home