Thread overview
No line numbers in stack trace (again)
Dec 05
Nordlöw
December 05
If I get the following stack trace ___without line numbers___ (instead ??:?) what's missing?

core.exception.AssertError@src/knet/linking.d(444): Assertion failure
----------------
??:? _d_assertp [0x5092ab19]
??:? pure @safe knet.storage.Edge knet.linking.dlink!(knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf[], knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf[]).dlink(knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf[], knet.rel.Rel, knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf[], knet.origins.Origin, double, bool) [0x5081b323]
??:? pure @safe knet.storage.Edge knet.linking.dlink(knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf, knet.rel.Rel, knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf, knet.origins.Origin, double, bool) [0x50819ec6]
??:? pure @safe knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf knet.patterns.oneOrMore(knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf) [0x508400aa]
??:? pure @safe knet.storage.ZingOf!(knet.storage.NodeInst).ZingOf knet.patterns.nounPhrase(knet.base.Db, languages.Lang) [0x508401d4]
??:? pure @safe void knet.patterns.__unittest_src_knet_patterns_d_286_3() [0x50841afb]
??:? void knet.patterns.__modtest() [0x50841d1f]
??:? int core.runtime.runModuleUnitTests().__foreachbody2(object.ModuleInfo*) [0x5094d98c]
??:? int object.ModuleInfo.opApply(scope int delegate(object.ModuleInfo*)).__lambda2(immutable(object.ModuleInfo*)) [0x509229d2]
??:? int rt.minfo.moduleinfos_apply(scope int delegate(immutable(object.ModuleInfo*))).__foreachbody2(ref rt.sections_elf_shared.DSO) [0x50933001]
??:? int rt.sections_elf_shared.DSO.opApply(scope int delegate(ref rt.sections_elf_shared.DSO)) [0x50933090]
??:? int rt.minfo.moduleinfos_apply(scope int delegate(immutable(object.ModuleInfo*))) [0x50932f8d]
??:? int object.ModuleInfo.opApply(scope int delegate(object.ModuleInfo*)) [0x509229a9]
??:? runModuleUnitTests [0x5094d870]
??:? void rt.dmain2._d_run_main(int, char**, extern (C) int function(char[][])*).runAll() [0x5092e29a]
??:? void rt.dmain2._d_run_main(int, char**, extern (C) int function(char[][])*).tryExec(scope void delegate()) [0x5092e233]
??:? _d_run_main [0x5092e1a3]
??:? main [0x506833e9]
??:? __libc_start_main [0xb9a7b1c0]


I'm compiling with flags

-vcolumns -dip25 -vcolumns -dip25 -vcolumns -dip25 -c -of.dub/build/application-unittest-linux.posix-x86_64-dmd_2077-CB3BD7AAC3F0D7B6FD8DE72BF286ACE5/knetquery.o -debug -g -unittest -w

and using DMD 2.077.1
December 12
On 12/05/2017 08:43 AM, Nordlöw wrote:
> If I get the following stack trace ___without line numbers___ (instead ??:?) what's missing?
> 

Linux stack trace line numbers have disappeard for me, too. Used to work. Very frustrating, and a royal PITA when dealing with unittests. Help would be appreciated. Could it be a PIC thing?
December 12
On Tuesday, 5 December 2017 at 13:43:38 UTC, Nordlöw wrote:
> If I get the following stack trace ___without line numbers___ (instead ??:?) what's missing?

> and using DMD 2.077.1

https://issues.dlang.org/show_bug.cgi?id=18068