On 20 April 2013 19:17, jerro <a@a.com> wrote:
Can do.

That would be nice :)


Now we are freed from the shackles of GCC attributes, we can give some of the attributes better or alternative names.

Personally, I'm fine with the names noinline and always_inline. If you are looking for alternative names, one option would be to use forceinline instead of always_inline.


And it's in:

https://github.com/D-Programming-GDC/GDC/commit/3e16d4d7673e4b3b8750df8bc92ce853199a2e78

--
Iain Buclaw

*(p < e ? p++ : p) = (c & 0x0f) + '0';