April 01

On Thursday, 1 April 2021 at 07:27:38 UTC, Vladimir Panteleev wrote:

>

(This post best viewed on forum.dlang.org!)

Greetings esteemed forum users,

I am delighted to announce that as of today, you can use rich text formatting in forum.dlang.org messages.

This is awesome! Thanks Vladimir!

April 01
On Thursday, 1 April 2021 at 07:27:38 UTC, Vladimir Panteleev wrote:
> I am delighted to announce that as of today, you can use rich text formatting in forum.dlang.org messages.

With Markdown enabled, the forum now eats HTML tags. If I enter "<foo>" and hit "save and preview", I see nothing.

Worse, this also happens to quoted text. So if someone else wrote "<foo>" with Markdown disabled, and I reply to that message with Markdown enabled, the quote gets garbled. This also affects entities (e.g. "&#x1F608;").
April 01

On Thursday, 1 April 2021 at 16:21:42 UTC, ag0aep6g wrote:

>

Worse, this also happens to quoted text. So if someone else wrote "" with Markdown disabled, and I reply to that message with Markdown enabled, the quote gets garbled. This also affects entities (e.g. "😈").

Replying to myself with Markdown enabled to demonstrate the effect.

April 01
On 4/1/2021 12:27 AM, Vladimir Panteleev wrote:
> I am delighted to announce that as of today, you can use rich text formatting in forum.dlang.org messages.

I am delighted that you've added this! Sweet!

Inevitably, I have a suggestion. I've been opposed to adding Markdown support to Ddoc. But some has been added, and I was wrong. Ddoc needs to support Markdown.

I recommend adding some Markdown to Dfeed. As to which flavor of Markdown, use the one we're familiar with - the Github flavor.
April 01
After a failed test, Vladimir wrote the following in private email:

<quote>
That post has the header:

Content-Type: text/plain; charset=utf-8; format=flowed

So, it's not rendered as Markdown because there is no
"markup=markdown" announced there.
</quote>

My problem is, I cannot find a way to add that in Thunderbird. Doing what the following page suggests about .headers and .header for "Content-Type" seemingly quietly fails and as a result, although the message is sent, e.g. the Subject line disappears. Information here:

  http://kb.mozillazine.org/Custom_headers

Ali's warning: Do not do the following; it does not work and at least the Subject header disappears.

    user_pref("mail.identity.id4.headers", "markdown");
    user_pref("mail.identity.id4.header.markdown", "Content-Type: markup=markdown");

On the other hand, I am able to add headers other than Content-Type. So, perhaps Vladimir can support something like the following?

  X-Markup: markdown

Ali

April 01
writeln("This is great, thanks!");
April 01

On Thursday, 1 April 2021 at 07:27:38 UTC, Vladimir Panteleev wrote:

>

$(SCRIPT ...), which allows embedding arbitrary JavaScript

lol, good one!

April 01

On Thursday, 1 April 2021 at 07:27:38 UTC, Vladimir Panteleev wrote:

>

(This post best viewed on forum.dlang.org!)

[...]

This is the best day of my life. Thank you!

April 01
On 4/1/2021 12:27 AM, Vladimir Panteleev wrote:
> And if the above is not sufficient to express your intent, there is the nuclear option: `$(SCRIPT ...)`, which allows embedding arbitrary JavaScript to format your post in however way you desire. jQuery is preloaded, so go nuts!

I'm concerned about running arbitrary scripts - what if bad people post malicious scripts that unsuspecting forum readers may run by reading the message? Could the Dfeed server be compromised by them?
April 01

On Thursday, 1 April 2021 at 14:50:31 UTC, Steven Schveighoffer wrote:

>

Check your settings to make sure ddoc processing is turned on.

I see no entry in the settings "ddoc processing".

I see the checkbox for Markdown in the editor, though. That's all I need.

I'm using Firefox.

1 2 3 4 5 6 7