November 08
WTF, why i got a this modal messagebox when i trying `dub test --build=unittest` ??
i just captured messagebox and using OCR, and that's it. here:
----------------------------------------
core.exceptionAssertError@source\dub\internal\vibecompat\core\log.d(85): Enforcement failed (No error)

0x00594079 in _d_assert_msg
Ox0056A55D in nothrow @safe void
dub.intemal.vibecompatcore.logiogErrorRimmutable(chae.lo
gError(immutable(char)g, lazy immutable(char)g) at
CWUsersWvagrantVklonesVidubVisourceVeduhAVinternalWvibeco
mpatwcorewlog.d(47)
Ox00409C24 in int
dub.commandline.runDubCommandLine(immutable(chaOgg) at
CWUsersWvagrantVklonesVidubVisourceViduhAikommandline.d(
272)
Ox0040256E in _Dmain at
CWUsersWvagrantVklonesWdubVisourceWapp.d(15)
Ox00592DDF in void rtdmain2._d_run_mainent, char*, extern
(C) int function(chargr).runA110._lambdal 0
Ox00592D61 in void rtdmain2._d_run_mainent, char", extern
(C) int function(chargg)").runAll0
Ox00592BFB in _d_run_main
Ox0040894C in main at
CV/UsersWvagrantVklonesVidubVisourceiVapp.d(7)
Ox0060D535 in mainCRTStartup
0x77608484 in BaseThreadlnitThunk
Ox77E13O5A in RtlValidSecurityDescriptor
Ox77E1302A in RtlValidSecurityDescriptor
----------------------------------------

yah, `dub test --build=unittest` didn't work. a dub made a test file for library(eg. libname-test-library.exe), but couldn't executed it. WHY???

But it didnt have no problem, when i tried executing `libname-test-library.exe` directly. WHY???

i have no idea.
November 08
On Thursday, 8 November 2018 at 15:01:04 UTC, duge wrote:
> WTF, why i got a this modal messagebox when i trying `dub test --build=unittest` ??
> i just captured messagebox and using OCR, and that's it. here:
> ----------------------------------------
> core.exceptionAssertError@source\dub\internal\vibecompat\core\log.d(85): Enforcement failed (No error)
>
> 0x00594079 in _d_assert_msg
> Ox0056A55D in nothrow @safe void
> dub.intemal.vibecompatcore.logiogErrorRimmutable(chae.lo
> gError(immutable(char)g, lazy immutable(char)g) at
> CWUsersWvagrantVklonesVidubVisourceVeduhAVinternalWvibeco
> mpatwcorewlog.d(47)
> Ox00409C24 in int
> dub.commandline.runDubCommandLine(immutable(chaOgg) at
> CWUsersWvagrantVklonesVidubVisourceViduhAikommandline.d(
> 272)
> Ox0040256E in _Dmain at
> CWUsersWvagrantVklonesWdubVisourceWapp.d(15)
> Ox00592DDF in void rtdmain2._d_run_mainent, char*, extern
> (C) int function(chargr).runA110._lambdal 0
> Ox00592D61 in void rtdmain2._d_run_mainent, char", extern
> (C) int function(chargg)").runAll0
> Ox00592BFB in _d_run_main
> Ox0040894C in main at
> CV/UsersWvagrantVklonesVidubVisourceiVapp.d(7)
> Ox0060D535 in mainCRTStartup
> 0x77608484 in BaseThreadlnitThunk
> Ox77E13O5A in RtlValidSecurityDescriptor
> Ox77E1302A in RtlValidSecurityDescriptor
> ----------------------------------------
>
> yah, `dub test --build=unittest` didn't work. a dub made a test file for library(eg. libname-test-library.exe), but couldn't executed it. WHY???
>
> But it didnt have no problem, when i tried executing `libname-test-library.exe` directly. WHY???
>
> i have no idea.

oh, sorry... my mistake. the content was mix. here is my original article:



WTF, why i got a this modal messagebox when i trying `dub test
--build=unittest` ??
i just captured messagebox and using OCR, and that's it. here:
----------------------------------------
core.exceptionAssertError@source\dub\internal\vibecompat\core\log.d(85): Enforcement failed (No error)
>
0x00594079 in _d_assert_msg
Ox0056A55D in nothrow @safe void
dub.intemal.vibecompatcore.logiogErrorRimmutable(chae.lo
gError(immutable(char)g, lazy immutable(char)g) at
CWUsersWvagrantVklonesVidubVisourceVeduhAVinternalWvibeco
mpatwcorewlog.d(47)
Ox00409C24 in int
dub.commandline.runDubCommandLine(immutable(chaOgg) at
CWUsersWvagrantVklonesVidubVisourceViduhAikommandline.d(
272)
Ox0040256E in _Dmain at
CWUsersWvagrantVklonesWdubVisourceWapp.d(15)
Ox00592DDF in void rtdmain2._d_run_mainent, char*, extern
(C) int function(chargr).runA110._lambdal 0
Ox00592D61 in void rtdmain2._d_run_mainent, char", extern
(C) int function(chargg)").runAll0
Ox00592BFB in _d_run_main
Ox0040894C in main at
CV/UsersWvagrantVklonesVidubVisourceiVapp.d(7)
Ox0060D535 in mainCRTStartup
0x77608484 in BaseThreadlnitThunk
Ox77E13O5A in RtlValidSecurityDescriptor
Ox77E1302A in RtlValidSecurityDescriptor
----------------------------------------

yah, `dub test --build=unittest` didn't work. the dub made a test file for library(eg. libname-test-library.exe) successfull but couldn't  executed it. WHY???

one of thing funny, it was work clearly when i tried executing `libname-test-library.exe` directly. WHY???

i have no idea.