Thread overview
How does this error from dub mean "dlang Non-selected Y package is available with version X"?
Feb 12
Marc
Feb 12
Seb
Feb 12
Marc
February 12
the warning is:

> Non-selected package lnk is available with version ~>0.2.1.

What does it mean by *Non-selected* package lnk is available?
from what I could tell from the page, it's highest version.
But I've tried low versions anyway to see if it Works 0.2.0, 0.1.1 etc and none did.

I noticied I put "lnk": "~>0.2.1" on cachedUpgrades section so I moved there to just created "dependencies" section then the dub's error is gone but it fail to find the lnk library:

> Error: module lnk is in file 'lnk.d' which cannot be read

some info:

The package I'm trying to include is: https://code.dlang.org/packages/lnk
DUB version 1.5.0, built on Sep  1 2017
DMD32 D Compiler v2.076.0
Windows 10/64bit

What am I missing? I'm new to dub so everything is new to me, by now.
February 12
On Monday, 12 February 2018 at 15:51:58 UTC, Marc wrote:
> the warning is:
>
>> Non-selected package lnk is available with version ~>0.2.1.
>
> What does it mean by *Non-selected* package lnk is available?
> from what I could tell from the page, it's highest version.
> But I've tried low versions anyway to see if it Works 0.2.0, 0.1.1 etc and none did.
>
> I noticied I put "lnk": "~>0.2.1" on cachedUpgrades section so I moved there to just created "dependencies" section then the dub's error is gone but it fail to find the lnk library:
>
>> Error: module lnk is in file 'lnk.d' which cannot be read
>
> some info:
>
> The package I'm trying to include is: https://code.dlang.org/packages/lnk
> DUB version 1.5.0, built on Sep  1 2017
> DMD32 D Compiler v2.076.0
> Windows 10/64bit
>
> What am I missing? I'm new to dub so everything is new to me, by now.

1) What's your dub.sdl / dub.json?
2) Did you try dub upgrade?
February 12
On Monday, 12 February 2018 at 15:51:58 UTC, Marc wrote:
> the warning is:
>
>> Non-selected package lnk is available with version ~>0.2.1.
>
> What does it mean by *Non-selected* package lnk is available?
> from what I could tell from the page, it's highest version.
> But I've tried low versions anyway to see if it Works 0.2.0, 0.1.1 etc and none did.
>
> I noticied I put "lnk": "~>0.2.1" on cachedUpgrades section so I moved there to just created "dependencies" section then the dub's error is gone but it fail to find the lnk library:
>
>> Error: module lnk is in file 'lnk.d' which cannot be read
>
> some info:
>
> The package I'm trying to include is: https://code.dlang.org/packages/lnk
> DUB version 1.5.0, built on Sep  1 2017
> DMD32 D Compiler v2.076.0
> Windows 10/64bit
>
> What am I missing? I'm new to dub so everything is new to me, by now.

so I find the issue. I'm ashamed to say: I was editing the dub.json inside the dub folder not the one in the my application's root.