August 07, 2019
On Tuesday, 6 August 2019 at 22:57:52 UTC, a11e99z wrote:
> On Tuesday, 6 August 2019 at 20:20:13 UTC, Sebastiaan Koppe wrote:
>> On Tuesday, 6 August 2019 at 19:02:09 UTC, a11e99z wrote:
>>> hi. can not compile for Windows
>>> LDC ver 1.16.0.
>> Currently ldc 1.16.0 isn't supported. You can downgrade to ldc 1.15.0
>>>> spasm 0.1.13: target for configuration "library" is up to date.
>>>> test_spasm ~master: building configuration "application"...
>>>> Error: unrecognized file extension lib               <<<<<<<<
>>>>  ??????
>>>> ldc2 failed with exit code 1.
>> Have you tried the github issues? I remember dukc having the same issue on windows as well.
> tried. --combined => got error about time.d. could not fix, idk how to fix.

Read further down the github issue. You have to hack some included DUB libraries, unless you can come up with a cleaner solution than I did.

> LDC 1.16.0 is working (it compiles manually)

ldc2 1.16.0 will compile the code, but not link it. And if you want to run ldc2 manually, you will want to dry-run dub with verbose and copy the invocation from it. A `--combined` build is too complicated to get working otherwise.

Don't mind DUB trying to build an executable. In fact, it has to be. If it builds a "library", it will silently generate some code that's not WASM, or at least can't be used as WASM. The file extension will be incorrect, but you can change it. Sebastiaan just recently opened a LDC2 issue for that.

1 2 3
Next ›   Last »