March 30, 2016
On 3/30/2016 5:58 AM, Steven Schveighoffer wrote:
> Thanks for the feedback.

And thanks for writing the article. Much appreciated.

March 30, 2016
On Tue, Mar 29, 2016 at 11:25:27AM -0400, Steven Schveighoffer via Digitalmars-d-announce wrote:
> I anticipate 2.071.0 is going to cause a lot of deprecation messages and strange errors to occur, due to the fixes of very long-standing import bugs.
> 
> I wrote a blog post (actually my first ever) on this, let me know what
> you think (and please, any clarifications/errors, let me know):
> 
> http://www.schveiguy.com/blog/2016/03/import-changes-in-d-2-071/

Excellent, thanks for writing this up!


T

-- 
Computers are like a jungle: they have monitor lizards, rams, mice, c-moss, binary trees... and bugs.
March 31, 2016
On 3/30/16 3:24 PM, Walter Bright wrote:
> On 3/30/2016 5:58 AM, Steven Schveighoffer wrote:
>> Thanks for the feedback.
>
> And thanks for writing the article. Much appreciated.
>

You're welcome :)

-Steve
April 01, 2016
On Wednesday, 30 March 2016 at 12:58:00 UTC, Steven Schveighoffer wrote:
> Sound better?

Yeah, thanks.

>> Not sure if it's worth it to repeat after each example. Feels redundant.
>
> I think it's important to state the previous and new behavior, even though it's always the same. It does sound redundant, but makes it easier to understand.

That's reasonable. You could kinda "compress" this, however - full description on first occurrence and a brief one later on. This is a common practice AFAICT:

> With 2.070 and prior versions, compiling this works just fine. With 2.071 and above, you will get either a deprecation warning, or an error.

--> "With 2.070 and prior versions, compiling this works just fine. In 2.071 it's deprecated (meaning you will get a warning now and compilation error with some later version of the compiler)"

> With 2.070, this compiled just fine. However, printf is supposed to be a private symbol of module ex2_a. With 2.071 and above, this will trigger a deprecation warning. In the future, the code will trigger an error.

--> "Fine with 2.070, deprecated in 2.071 because printf is supposed to be a private symbol of module ex2_a"

> In 2.070, this produces no warning or error. In 2.071 and beyond, this will produce a deprecation warning, and eventually an error.

--> "Fine with 2.070, deprecated in 2.071"


Anyway, not a big deal. Sorry if I've gone too far with nitpicking :) Thanks for the article!

-Alexander
Next ›   Last »
1 2