Thread overview
GDC buildable on solaris?
Apr 17
kdevel
March 13

Hi GDC

I'm temporarily working on an old solaris big-endian system, which happens to have GCC 4.9. I think this could be recent enough to boot-strap gcc-11.2 (and of course gdc). But before I attempt to build gdc on such an odd beast, does anyone know if gdc is big-endian safe? Would it even be worth the attempt?

Thanks ...and thanks for gdc.

March 13

On Sunday, 13 March 2022 at 06:46:47 UTC, Chris Piker wrote:

>

Hi GDC

I'm temporarily working on an old solaris big-endian system, which happens to have GCC 4.9. I think this could be recent enough to boot-strap gcc-11.2 (and of course gdc). But before I attempt to build gdc on such an odd beast, does anyone know if gdc is big-endian safe? Would it even be worth the attempt?

Thanks ...and thanks for gdc.

  1. Yes, the minimum version required to bootstrap latest version of gcc is 4.8 (ISO C++11 compiler).

  2. Current mainline gdc requires a D compiler, so the minimum version to bootstrap is 9.1 - though preferably you should have at least 9.4 or 10.1 because of belated bugs that were discovered too late on some platforms when verifying their ability to bootstrap themselves.

  3. gdc (and the dmd front-end) is big-endian and strict-alignment safe, sometimes upstream wobbles a bit an introduces regressions - there have been a few since 2.076..2.099 - but those have caught early enough in development that they are no longer a problem.

To highlight a couple examples in both the compiler and D runtime library.
https://github.com/dlang/dmd/pull/13324
https://github.com/dlang/dmd/pull/13703
https://github.com/dlang/druntime/pull/3774
https://github.com/dlang/druntime/pull/3775

  1. gdc is routinely compiled and tested on Solaris i386 and sparc. An incoming merge is about to land that should reduce the number of fails tests in the dmd testsuite on sparc. (See the linked druntime patches ;-)
April 17

On Sunday, 13 March 2022 at 11:09:56 UTC, Iain Buclaw wrote:

>

[...]
2. Current mainline gdc requires a D compiler, so the minimum version to bootstrap is 9.1 - though preferably you should have at least 9.4 or 10.1 because of belated bugs that were discovered too late on some platforms when verifying their ability to bootstrap themselves.
[...]

Is it correct that "current mainline" implies GCC-12? Few days ago I bootstrapped GCC/GDC 11.2 without having a gdc installed. configure of GCC 12 now says:

configure: error: GDC is required to build d