March 26
On a Raspberry pi, ARM 32-bit, not 64-bit o/s unfortunately, running Ubuntu, I'm trying to get hold of the latest LDC to run it on ARM itself (ie not cross-compiling from an x86 dev system to an ARM target, but ARM on ARM).

I did a
   curl -fsS https://dlang.org/install.sh | bash -s ldc
but from the script, I get
    "Unsupported Arch armv7l"

* I can apt-get some version of LDC, but I don't know how out of date that package might be?
March 26
On Monday, 26 March 2018 at 06:47:12 UTC, Cecil Ward wrote:
> On a Raspberry pi, ARM 32-bit, not 64-bit o/s unfortunately, running Ubuntu, I'm trying to get hold of the latest LDC to run it on ARM itself (ie not cross-compiling from an x86 dev system to an ARM target, but ARM on ARM).
>
> I did a
>    curl -fsS https://dlang.org/install.sh | bash -s ldc
> but from the script, I get
>     "Unsupported Arch armv7l"
>
> * I can apt-get some version of LDC, but I don't know how out of date that package might be?

That script doesn't support non-x86/x64 yet, just get the latest ldc here:

https://github.com/ldc-developers/ldc/releases