Thread overview
Fuzzing with LDC
May 09
kinke
May 08
When I compile my program with the LDC -fsanitize=fuzzer option I get linking errors, as if the fuzzing library was not installed or linked with. But the libFuzzer web page says that "LibFuzzer is built as a part of LLVM project by default on macos and Linux", and I'm on macOS. Also, the same happens when I use an LDC I had built from SVN a bit ago (--version identifies as "LLVM version 7.0.0svn"). Same thing when I build LDC from git head using "brew install --HEAD ldc".

What's the easiest way to get fuzzing working with LDC on macOS?
May 08
On Tuesday, 8 May 2018 at 23:12:31 UTC, Luís Marques wrote:
> Also, the same happens when I use an LDC I had built from SVN a bit ago (--version identifies as "LLVM version 7.0.0svn").

I meant an LDC I had built with an LLVM I built from SVN.
May 09
On Tuesday, 8 May 2018 at 23:12:31 UTC, Luís Marques wrote:
> What's the easiest way to get fuzzing working with LDC on macOS?

Using the official prebuilt release package probably. - libFuzzer is part of the compiler-rt repo and not included in the LLVM source tree. If you wanna build LLVM yourself, I suggest using the source tarball of our fork, which includes compiler-rt: https://github.com/ldc-developers/llvm/releases