February 01
On Thursday, 31 January 2019 at 20:33:43 UTC, Ron Tarrant wrote:
> On Wednesday, 30 January 2019 at 21:21:24 UTC, Mike Wey wrote:
>
>> This is whats going on: https://issues.dlang.org/show_bug.cgi?id=15418
>>
>> To work around this you can either build things with "--arch=x86mscoff" or tell dub not to build the debug version with "--build=plain".
>
> Ah! Thanks, Mike. Does the lack of an answer to the last question there mean that this is an on-going issue?

The issue is unrelated to dub. It only has to do with object format and linker that dmd uses on Windows by default.
This issue is perhaps the reason why you had to use the -m64 dmd flag in your first post. If you don't specify the target arch on Windows - the -mXX flag for dmd, or the --arch=YYY flag for dub - the default is going to be -m32 and --arch=x86 respectively.

So, assuming you have the MSVC C++ toolchain installed, just build with dub by specifying either the --arch=x86_mscoff or --arch=x86_64 flags.
But no one should ever need to modify their dmd installation, in order to use gtkd.

February 01
On Friday, 1 February 2019 at 07:43:23 UTC, Petar Kirov [ZombineDev] wrote:
> So, assuming you have the MSVC C++ toolchain installed, just build with dub by specifying either the --arch=x86_mscoff or --arch=x86_64 flags.
> But no one should ever need to modify their dmd installation, in order to use gtkd.

I don't think you still need ms toolchain installed: dmd comes with lld linker and mingw libs.
February 02
On Friday, 1 February 2019 at 07:43:23 UTC, Petar Kirov [ZombineDev] wrote:

> But no one should ever need to modify their dmd installation, in order to use gtkd.

Too true. It's one of the reasons I'm sticking with dmd for now. I followed a simple set of instructions to get an environment set up, the same instructions I posted on the blog. And I'm thinking the simplest way for a blog reader to get to a compiled product is the way I've outlined. Perhaps I'm wrong about that, but it's what I'm aiming for, the least fuss, the least work, the least complexity.
February 06
On Saturday, 2 February 2019 at 17:01:28 UTC, Ron Tarrant wrote:
> It's one of the reasons I'm sticking with dmd for now.

This morning, after creating the file:

    C:\ProgramData\dub\settings.json

with contents:

    {
	"defaultArchitecture": "x86_64",
	"defaultCompiler": "ldc"
    }


I ran some more tests with dub and successfully compiled/ran some of my GtkD example code. (Yay!)

At some point, I guess I'd better write this up and post it.
February 06
On Wednesday, 6 February 2019 at 16:53:49 UTC, Ron Tarrant wrote:
> On Saturday, 2 February 2019 at 17:01:28 UTC, Ron Tarrant wrote:

> I ran some more tests with dub and successfully compiled/ran some of my GtkD example code. (Yay!)
>
> At some point, I guess I'd better write this up and post it.

Oddly, if I type:

    dub init

in a git bash shell, it just wanders off like my grandmother when she's off her meds.

But it works fine from the Windows 10 command prompt.
Next ›   Last »
1 2 3 4