Jump to page: 1 2
Thread overview
August 09
Which version of dub support dub add library name?

Dub add is not supported in dub 1.11.0

Besides I could not run rdmd on my windows 10 core i7. It days this app cannot run on this machine

What is the way out? Where can I get window binary for dub that is higher than dub 1.11.0

August 09
> Dub add is not supported in dub 1.11.0

Use 'dub fetch'.

August 09
On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote:
>> Dub add is not supported in dub 1.11.0
>
> Use 'dub fetch'.



dub fetch dub
Fetching dub 1.16.0...
Please note that you need to use `dub run <pkgname>` or add it to dependencies of your package to actually use/run it. dub does not do actual installation of packages outside of its own ecosystem.


besides in https://code.dlang.org/packages/arsd-official they said use dub add arsd-official


August 09
On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote:
> On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote:
>>> Dub add is not supported in dub 1.11.0
>>
>> Use 'dub fetch'.
>
>
>
> dub fetch dub
> Fetching dub 1.16.0...
> Please note that you need to use `dub run <pkgname>` or add it to dependencies of your package to actually use/run it. dub does not do actual installation of packages outside of its own ecosystem.
>
>
> besides in https://code.dlang.org/packages/arsd-official they said use dub add arsd-official

Instead if specifying a dub package manually in your project dub.json thr command dub add will edit the dub.json for you.

Normally you get dub with the dmd/ldc/gdc package. Just download/install a recent package compiler package if you want to have command dub add.

Kind regards
Andre
August 09
On Friday, 9 August 2019 at 03:52:11 UTC, Andre Pany wrote:
> On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote:
>> On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote:
>>> [...]
>>
>>
>>
>> dub fetch dub
>> Fetching dub 1.16.0...
>> Please note that you need to use `dub run <pkgname>` or add it to dependencies of your package to actually use/run it. dub does not do actual installation of packages outside of its own ecosystem.
>>
>>
>> besides in https://code.dlang.org/packages/arsd-official they said use dub add arsd-official
>
> Instead if specifying a dub package manually in your project dub.json thr command dub add will edit the dub.json for you.
>
> Normally you get dub with the dmd/ldc/gdc package. Just download/install a recent package compiler package if you want to have command dub add.
>
> Kind regards
> Andre


I am using dmd 2.087.1 and dub 1.11.0

But the command dub add... Did not work

rdmd cannot run on my system.
August 09
On Friday, 9 August 2019 at 08:30:49 UTC, GreatSam4sure wrote:
> On Friday, 9 August 2019 at 03:52:11 UTC, Andre Pany wrote:
>> On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote:
>>> On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote:
>>>> [...]
>>>
>>>
>>>
>>> dub fetch dub
>>> Fetching dub 1.16.0...
>>> Please note that you need to use `dub run <pkgname>` or add it to dependencies of your package to actually use/run it. dub does not do actual installation of packages outside of its own ecosystem.
>>>
>>>
>>> besides in https://code.dlang.org/packages/arsd-official they said use dub add arsd-official
>>
>> Instead if specifying a dub package manually in your project dub.json thr command dub add will edit the dub.json for you.
>>
>> Normally you get dub with the dmd/ldc/gdc package. Just download/install a recent package compiler package if you want to have command dub add.
>>
>> Kind regards
>> Andre
>
>
> I am using dmd 2.087.1 and dub 1.11.0
>
> But the command dub add... Did not work
>
> rdmd cannot run on my system.

My assumption is, you have several dub executables on your computer. A recent one, bundled with dmd, and an old 1.11.0. Delete the old one, this should solve your problem.

Please provide more information what you mean with "rdmd does not work". In general rdmd is superseded by the command "dmd -run".

Kind regards
Andre
August 09
On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote:
> On Friday, 9 August 2019 at 08:30:49 UTC, GreatSam4sure wrote:
>> On Friday, 9 August 2019 at 03:52:11 UTC, Andre Pany wrote:
>>> On Friday, 9 August 2019 at 01:36:43 UTC, greatsam4sure wrote:
>>>> On Friday, 9 August 2019 at 01:18:12 UTC, Elronnd wrote:
>>>>> [...]
>>>>
>>>>
>>>>
>>>> dub fetch dub
>>>> Fetching dub 1.16.0...
>>>> Please note that you need to use `dub run <pkgname>` or add it to dependencies of your package to actually use/run it. dub does not do actual installation of packages outside of its own ecosystem.
>>>>
>>>>
>>>> besides in https://code.dlang.org/packages/arsd-official they said use dub add arsd-official
>>>
>>> Instead if specifying a dub package manually in your project dub.json thr command dub add will edit the dub.json for you.
>>>
>>> Normally you get dub with the dmd/ldc/gdc package. Just download/install a recent package compiler package if you want to have command dub add.
>>>
>>> Kind regards
>>> Andre
>>
>>
>> I am using dmd 2.087.1 and dub 1.11.0
>>
>> But the command dub add... Did not work
>>
>> rdmd cannot run on my system.
>
> My assumption is, you have several dub executables on your computer. A recent one, bundled with dmd, and an old 1.11.0. Delete the old one, this should solve your problem.
>
> Please provide more information what you mean with "rdmd does not work". In general rdmd is superseded by the command "dmd -run".
>
> Kind regards
> Andre




I am at lost here. Before I can run my D project using dub.1.11.0 executable install on my system but after uninstalling and install dmd 2.087.1 cannot run my project using dub from the project root folder. In windows 10 it shows this app can't run on your PC. To find a version for your PC, check with the software publisher. The same how's for the com and rdmd


What is the way out.

August 09
On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote:
> On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote:
>> On Friday, 9 August 2019 at 08:30:49 UTC, GreatSam4sure wrote:
>>> [...]
>>
>> My assumption is, you have several dub executables on your computer. A recent one, bundled with dmd, and an old 1.11.0. Delete the old one, this should solve your problem.
>>
>> Please provide more information what you mean with "rdmd does not work". In general rdmd is superseded by the command "dmd -run".
>>
>> Kind regards
>> Andre
>
>
>
>
> I am at lost here. Before I can run my D project using dub.1.11.0 executable install on my system but after uninstalling and install dmd 2.087.1 cannot run my project using dub from the project root folder. In windows 10 it shows this app can't run on your PC. To find a version for your PC, check with the software publisher. The same how's for the com and rdmd
>
>
> What is the way out.

With recent version of Dub the default architecture changed from x86 to x86_64. You can force the old architecture by using argument -a x86.

Does this help?

Kind regards
Andre
August 09
On Friday, 9 August 2019 at 13:01:51 UTC, Andre Pany wrote:
> On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote:
>> On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote:
>>> [...]
>>
>>
>>
>>
>> I am at lost here. Before I can run my D project using dub.1.11.0 executable install on my system but after uninstalling and install dmd 2.087.1 cannot run my project using dub from the project root folder. In windows 10 it shows this app can't run on your PC. To find a version for your PC, check with the software publisher. The same how's for the com and rdmd
>>
>>
>> What is the way out.
>
> With recent version of Dub the default architecture changed from x86 to x86_64. You can force the old architecture by using argument -a x86.
>
> Does this help?
>
> Kind regards
> Andre


No luck sir. I can only run D app by installing dub 1.11.0.

Just to be clear, are you saying once DMD is installed I don't need to install dub again or add it as a dependency to app?
Pls clarify.

August 09
On Friday, 9 August 2019 at 13:59:51 UTC, GreatSam4sure wrote:
> On Friday, 9 August 2019 at 13:01:51 UTC, Andre Pany wrote:
>> On Friday, 9 August 2019 at 12:10:21 UTC, GreatSam4sure wrote:
>>> On Friday, 9 August 2019 at 09:01:54 UTC, Andre Pany wrote:
>>>> [...]
>>>
>>>
>>>
>>>
>>> I am at lost here. Before I can run my D project using dub.1.11.0 executable install on my system but after uninstalling and install dmd 2.087.1 cannot run my project using dub from the project root folder. In windows 10 it shows this app can't run on your PC. To find a version for your PC, check with the software publisher. The same how's for the com and rdmd
>>>
>>>
>>> What is the way out.
>>
>> With recent version of Dub the default architecture changed from x86 to x86_64. You can force the old architecture by using argument -a x86.
>>
>> Does this help?
>>
>> Kind regards
>> Andre
>
>
> No luck sir. I can only run D app by installing dub 1.11.0.
>
> Just to be clear, are you saying once DMD is installed I don't need to install dub again or add it as a dependency to app?
> Pls clarify.

The package manager Dub is included within  the DMD archive / DMD setup executable.

Does you have the problem also for a simple hello world sub project?

Please execute:

dub init sample1
cd sample1
dub build -a x86
sample1.exe

Kind regards
Andre
« First   ‹ Prev
1 2