July 18, 2015
On Saturday, 18 July 2015 at 01:32:45 UTC, Andrei Alexandrescu wrote:
> On 7/17/15 8:20 PM, Mike wrote:
>> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>>> Should just be "Aliases".
>>
>> I'd be happy to do the pull request if you wish.
>
> Let's get the "+1"s on this - please reply. I'm fine with Aliases with an extra umph that the BDFL favors it. -- Andrei

_Please_ no. It'll just make it extra confusing whether you're talking about what was TypeTuple or just aliases in general. That's why I've never liked the name Array for std.container. You always have to be extra careful when talking about it to make it clear what you mean, and if you're actually talking instead of writing, it's that much worse. And honestly, I wouldn't expect a type to have a name which was plural, and I'd expect the fact that it's plural would just increase the confusion. And TypeTuple, AliasSeq, whatever is already confusing enough as a concept without naming it something that adds confusion on its own.

- Jonathan M Davis
July 18, 2015
On Saturday, 18 July 2015 at 01:35:03 UTC, Jonathan M Davis wrote:
> Then you have the confusion about whether you're talking about the replacement of TypeTuple or just aliases in general - especially if verbal conversation. AliasSeq won't be confused with anything.
>
> - Jonathan M Davis

That's the beauty of it and why, years ago when having yet another conversation about renaming TypeTuple, I was highly in favor of the name Timon (if memory serves) had been using for awhile: Seq. The long, long conversations have shown that there's no simple combination of words that describes it well so a neologism is the best possible option if you want to avoid confusion.

You could argue that a new word is harder for beginners but I'd argue that using existing words in a way that doesn't actually describe it accurately or precisely is far worse. TypeTuple confused me greatly as a beginner. In this very NG archive you can find me suggesting, to my embarrassment, the name "Type List" as a replacement because I thought I understood what it was. The flood of disagreements is what finally made me dig in and understand it. While I think AliasSeq is better, it's not much better and suffers from the unrelated baggage that comes with "Alias" so I still think Seq is better than AliasSeq.

(I haven't read any of this thread because I'm exhausted with this topic so just ignore me if you guys have already rehashed and dismissed Seq. I don't care enough about the outcome anymore to fight for it.)
July 18, 2015
On Saturday, 18 July 2015 at 01:35:03 UTC, Jonathan M Davis wrote:
> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>> Should just be "Aliases"....
>
> Then you have the confusion about whether you're talking about the replacement of TypeTuple or just aliases in general - especially if verbal conversation. AliasSeq won't be confused with anything.
>
> - Jonathan M Davis

I cannot think of one sentence that doesn't disambiguate.
July 18, 2015
On Saturday, 18 July 2015 at 01:32:45 UTC, Andrei Alexandrescu wrote:
> On 7/17/15 8:20 PM, Mike wrote:
>> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>>> Should just be "Aliases".
>>
>> I'd be happy to do the pull request if you wish.
>
> Let's get the "+1"s on this - please reply. I'm fine with Aliases with an extra umph that the BDFL favors it. -- Andrei

+1
July 18, 2015
On Fri, 17 Jul 2015 21:32:59 -0400, Andrei Alexandrescu wrote:

> On 7/17/15 8:20 PM, Mike wrote:
>> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>>> Should just be "Aliases".
>>
>> I'd be happy to do the pull request if you wish.
> 
> Let's get the "+1"s on this - please reply. I'm fine with Aliases with an extra umph that the BDFL favors it. -- Andrei

+1
July 18, 2015
On Saturday, 18 July 2015 at 01:32:45 UTC, Andrei Alexandrescu wrote:
> On 7/17/15 8:20 PM, Mike wrote:
>> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>>> Should just be "Aliases".
>>
>> I'd be happy to do the pull request if you wish.
>
> Let's get the "+1"s on this - please reply. I'm fine with Aliases with an extra umph that the BDFL favors it. -- Andrei

+1
July 18, 2015
On Saturday, 18 July 2015 at 01:32:45 UTC, Andrei Alexandrescu wrote:
> On 7/17/15 8:20 PM, Mike wrote:
>> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>>> Should just be "Aliases".
>>
>> I'd be happy to do the pull request if you wish.
>
> Let's get the "+1"s on this - please reply. I'm fine with Aliases with an extra umph that the BDFL favors it. -- Andrei

+1
July 18, 2015
On Saturday, 18 July 2015 at 01:32:45 UTC, Andrei Alexandrescu wrote:
> On 7/17/15 8:20 PM, Mike wrote:
>> On Friday, 17 July 2015 at 20:54:33 UTC, Walter Bright wrote:
>>
>>> Should just be "Aliases".
>>
>> I'd be happy to do the pull request if you wish.
>
> Let's get the "+1"s on this - please reply. I'm fine with Aliases with an extra umph that the BDFL favors it. -- Andrei

+1

The code would be just better to read and write with "Aliases".
To some extent I understand "confusion" point raised by others. However I not sure if it's overexaggerating.

Piotrek
July 18, 2015
On Saturday, 18 July 2015 at 02:07:42 UTC, Brad Anderson wrote:
> (I haven't read any of this thread because I'm exhausted with this topic so just ignore me if you guys have already rehashed and dismissed Seq. I don't care enough about the outcome anymore to fight for it.)

It has been dismissed for semantic reasons... people just gloss over it.

"Seq" is a term that is used in formal specification in CS that usually means sequence-of-values-with-type(X). Sequence-of-ints, sequence-of-chars…

In general usage, "sequence" usually implies a series of values where distance/order is important for interpretation: DNA-sequence, Fibonacci-sequence, instruction-sequence, animation-sequence, sequences in music scores (time series in general), the output of generators (recurrence relations etc), etc.

July 18, 2015
On Saturday, 18 July 2015 at 01:44:27 UTC, Jonathan M Davis wrote:
> On Saturday, 18 July 2015 at 01:32:45 UTC, Andrei Alexandrescu wrote:
>> [...]
>
> _Please_ no. It'll just make it extra confusing whether you're talking about what was TypeTuple or just aliases in general. That's why I've never liked the name Array for std.container. You always have to be extra careful when talking about it to make it clear what you mean, and if you're actually talking instead of writing, it's that much worse. And honestly, I wouldn't expect a type to have a name which was plural, and I'd expect the fact that it's plural would just increase the confusion. And TypeTuple, AliasSeq, whatever is already confusing enough as a concept without naming it something that adds confusion on its own.
>
> - Jonathan M Davis

Yup.