View mode: basic / threaded / horizontal-split · Log in · Help
February 06, 2012
GDC Build Failing
I'm having a failure compiling libgcc2.c - fatal error: gnu/stubs-32.h: 
No such file or directory.

I got round that by copying the file from /usr/include/i386-linux-gnu/gnu 
intp /usr/include/gnu.

Then the build goes on, but later I get get:

checking dynamic linker characteristics... configure: error: Link tests 
are not allowed after GCC_NO_EXECUTABLES.

Any suggestions?

Steve
February 06, 2012
Re: GDC Build Failing
Which distro?
February 06, 2012
Re: GDC Build Failing
On 6 February 2012 12:50, Steve Teale <steve.teale@britseyeview.com> wrote:
> I'm having a failure compiling libgcc2.c - fatal error: gnu/stubs-32.h:
> No such file or directory.
>
> I got round that by copying the file from /usr/include/i386-linux-gnu/gnu
> intp /usr/include/gnu.
>
> Then the build goes on, but later I get get:
>
> checking dynamic linker characteristics... configure: error: Link tests
> are not allowed after GCC_NO_EXECUTABLES.
>
> Any suggestions?
>
> Steve

Looks like you don't have 32bit headers installed on your machine.  If
you can't obtain them, build with --disable-multilib.


Regards.
-- 
Iain Buclaw

*(p < e ? p++ : p) = (c & 0x0f) + '0';
February 06, 2012
Re: GDC Build Failing
On Mon, 06 Feb 2012 13:17:00 +0000, Iain Buclaw wrote:

> On 6 February 2012 12:50, Steve Teale <steve.teale@britseyeview.com>
> wrote:
>> I'm having a failure compiling libgcc2.c - fatal error: gnu/stubs-32.h:
>> No such file or directory.
>>
>> I got round that by copying the file from
>> /usr/include/i386-linux-gnu/gnu intp /usr/include/gnu.
>>
>> Then the build goes on, but later I get get:
>>
>> checking dynamic linker characteristics... configure: error: Link tests
>> are not allowed after GCC_NO_EXECUTABLES.
>>
>> Any suggestions?
>>
>> Steve
> 
> Looks like you don't have 32bit headers installed on your machine.  If
> you can't obtain them, build with --disable-multilib.

OK, perhaps a pertinent question is what is the default build? I have 32 
bit Ubuntu installed on a 64 bit two core machine.

The header in question is there and specifically under i396-gnu, so I 
have some 32 bit headers. Would it not complain about others?

Steve

> 
> 
> Regards.
February 06, 2012
Re: GDC Build Failing
On 6 February 2012 16:14, Steve Teale <steve.teale@britseyeview.com> wrote:
> On Mon, 06 Feb 2012 13:17:00 +0000, Iain Buclaw wrote:
>
>> On 6 February 2012 12:50, Steve Teale <steve.teale@britseyeview.com>
>> wrote:
>>> I'm having a failure compiling libgcc2.c - fatal error: gnu/stubs-32.h:
>>> No such file or directory.
>>>
>>> I got round that by copying the file from
>>> /usr/include/i386-linux-gnu/gnu intp /usr/include/gnu.
>>>
>>> Then the build goes on, but later I get get:
>>>
>>> checking dynamic linker characteristics... configure: error: Link tests
>>> are not allowed after GCC_NO_EXECUTABLES.
>>>
>>> Any suggestions?
>>>
>>> Steve
>>
>> Looks like you don't have 32bit headers installed on your machine.  If
>> you can't obtain them, build with --disable-multilib.
>
> OK, perhaps a pertinent question is what is the default build? I have 32
> bit Ubuntu installed on a 64 bit two core machine.
>
> The header in question is there and specifically under i396-gnu, so I
> have some 32 bit headers. Would it not complain about others?
>
> Steve
>
>>
>>
>> Regards.
>

For Ubuntu and Debian, being that i386 and x86_64 (possibly others)
are multi-arch systems, you may need to set-up LIBRARY_PATH and CPATH.

In ~/.bashrc:

LIBRARY_PATH=/usr/lib/i386-linux-gnu
CPATH=/usr/include/i386-linux-gnu
export LIBRARY_PATH CPATH


I have said this at least a dozen times, this must be documented somewhere... :)

-- 
Iain Buclaw

*(p < e ? p++ : p) = (c & 0x0f) + '0';
February 07, 2012
Re: GDC Build Failing
On Mon, 06 Feb 2012 16:31:40 +0000, Iain Buclaw wrote:

>>
> For Ubuntu and Debian, being that i386 and x86_64 (possibly others) are
> multi-arch systems, you may need to set-up LIBRARY_PATH and CPATH.
> 
> In ~/.bashrc:
> 
> LIBRARY_PATH=/usr/lib/i386-linux-gnu
> CPATH=/usr/include/i386-linux-gnu
> export LIBRARY_PATH CPATH
> 
> 
> I have said this at least a dozen times, this must be documented
> somewhere... :)

That does the trick, but to avoid confusion, if you have already got into 
trouble it is best to remove objdir, close your terminal window, and 
start again from the point where objdir is created.

Thanks ever so
Steve
Top | Discussion index | About this forum | D home