Thread overview
Release candidate vibe.d 0.8.1-rc.1
Second release candidate 0.8.1-rc.2
Third release candidate vibe.d 0.8.1-rc.3
August 12
The first release candidate for 0.8.1 is out, notably containing some API fixes (mostly missing @safe annotations), as well as a bunch of improvements in the HTTP sub system. Full change log:

https://github.com/rejectedsoftware/vibe.d/blob/master/CHANGELOG.md

0.8.1-rc.1 on code.dlang.org:
http://code.dlang.org/packages/vibe-d/0.8.1-rc.1

The release is scheduled for Monday the 28th. Some time after, there will also be a 0.7.x release, which has the fixes that went into 0.8.0 and 0.8.1 backported, to keep the 0.7 branch alive for a bit longer.
August 12
On Saturday, 12 August 2017 at 07:55:14 UTC, Sönke Ludwig wrote:
> The first release candidate for 0.8.1 is out, notably containing some API fixes (mostly missing @safe annotations), as well as a bunch of improvements in the HTTP sub system. Full change log:
>
> https://github.com/rejectedsoftware/vibe.d/blob/master/CHANGELOG.md
>
> 0.8.1-rc.1 on code.dlang.org:
> http://code.dlang.org/packages/vibe-d/0.8.1-rc.1
>
> The release is scheduled for Monday the 28th. Some time after, there will also be a 0.7.x release, which has the fixes that went into 0.8.0 and 0.8.1 backported, to keep the 0.7 branch alive for a bit longer.

Do you anticipate that support for OpenSSL 1.1 will be provided in the 0.8.1 release?  Lack of support is blocking my compilation with vibe on Fedora 26.
August 12
Am 12.08.2017 um 10:41 schrieb Andrew Benton:
> On Saturday, 12 August 2017 at 07:55:14 UTC, Sönke Ludwig wrote:
>> The first release candidate for 0.8.1 is out, notably containing some API fixes (mostly missing @safe annotations), as well as a bunch of improvements in the HTTP sub system. Full change log:
>>
>> https://github.com/rejectedsoftware/vibe.d/blob/master/CHANGELOG.md
>>
>> 0.8.1-rc.1 on code.dlang.org:
>> http://code.dlang.org/packages/vibe-d/0.8.1-rc.1
>>
>> The release is scheduled for Monday the 28th. Some time after, there will also be a 0.7.x release, which has the fixes that went into 0.8.0 and 0.8.1 backported, to keep the 0.7 branch alive for a bit longer.
> 
> Do you anticipate that support for OpenSSL 1.1 will be provided in the 0.8.1 release?  Lack of support is blocking my compilation with vibe on Fedora 26.

Good point, I managed to forget about that. I'll at least include a manual solution that works with a version constant VibeUseOpenSSL11 or similar. Robert Schadek fortunately has a PR already open that just needs to be adjusted a bit.
August 12
v0.8.1-rc.2 now supports setting a version "VibeUseOpenSSL11" in the package recipe to compile against the OpenSSL 1.1.0 API on systems that don't have 1.0.1 anymore.
August 12
On Saturday, 12 August 2017 at 12:43:14 UTC, Sönke Ludwig wrote:
> v0.8.1-rc.2 now supports setting a version "VibeUseOpenSSL11" in the package recipe to compile against the OpenSSL 1.1.0 API on systems that don't have 1.0.1 anymore.

Thanks for making that change!
August 13
On Saturday, 12 August 2017 at 12:43:14 UTC, Sönke Ludwig wrote:
> v0.8.1-rc.2 now supports setting a version "VibeUseOpenSSL11" in the package recipe to compile against the OpenSSL 1.1.0 API on systems that don't have 1.0.1 anymore.

This is great, Thank you!
August 22
The latest RC fixes a build issue with the OpenSSL 1.1.0 compatibility code and adds Meson build files.