Thread overview
Beta 2.084.1
Feb 06
Seb
February 05
Glad to announce the first beta for the 2.084.1 point release, ♥ to the 6 contributors.

http://dlang.org/download.html#dmd_beta http://dlang.org/changelog/2.084.1.html

As usual please report any bugs at
https://issues.dlang.org

-Martin
February 05
On Tuesday, 5 February 2019 at 04:18:55 UTC, Martin Nowak wrote:
> Glad to announce the first beta for the 2.084.1 point release, ♥ to the 6 contributors.
>
> http://dlang.org/download.html#dmd_beta http://dlang.org/changelog/2.084.1.html
>
> As usual please report any bugs at
> https://issues.dlang.org
>
> -Martin

The link to the changelog is broken.
February 05
On Tuesday, 5 February 2019 at 04:18:55 UTC, Martin Nowak wrote:
> Glad to announce the first beta for the 2.084.1 point release, ♥ to the 6 contributors.
>
> http://dlang.org/download.html#dmd_beta http://dlang.org/changelog/2.084.1.html
>
> As usual please report any bugs at
> https://issues.dlang.org
>
> -Martin

This beta again has this issue:
lld-link.exe: error: could not open msvcrt100.lib: no such file or directory
lld-link.exe: error: could not open OLDNAMES.lib: no such file or directory

(It is caused if you have a visual studio / build tools installation, then
lld gets confused).

It was already solved in the nightly build, I downloaded some days ago.

Kind regards
André
February 05
On Tuesday, 5 February 2019 at 04:18:55 UTC, Martin Nowak wrote:
> Glad to announce the first beta for the 2.084.1 point release,

Any chance of getting this in?
https://github.com/dlang/phobos/pull/6814

Phobos std.file has become unusable after 2.082 because of [1] leading to memory corruption. It's pretty bad: dmd 2.082 and 2.083, and LDC 1.12 and 1.13 cannot be used for serious work (unless you prevent people from using std.file by deleting it?).

Cheers,
  Johan

[1] the trigger of the bug: https://github.com/dlang/phobos/pull/6584
February 06
On Tuesday, 5 February 2019 at 17:41:50 UTC, Johan Engelen wrote:
> On Tuesday, 5 February 2019 at 04:18:55 UTC, Martin Nowak wrote:
>> Glad to announce the first beta for the 2.084.1 point release,
>
> Any chance of getting this in?
> https://github.com/dlang/phobos/pull/6814

-> https://github.com/dlang/phobos/pull/6855
February 06

On 05/02/2019 11:53, Andre Pany wrote:
> On Tuesday, 5 February 2019 at 04:18:55 UTC, Martin Nowak wrote:
>> Glad to announce the first beta for the 2.084.1 point release, ♥ to the 6 contributors.
>>
>> http://dlang.org/download.html#dmd_beta http://dlang.org/changelog/2.084.1.html
>>
>> As usual please report any bugs at
>> https://issues.dlang.org
>>
>> -Martin
> 
> This beta again has this issue:
> lld-link.exe: error: could not open msvcrt100.lib: no such file or
> directory
> lld-link.exe: error: could not open OLDNAMES.lib: no such file or directory
> 
> (It is caused if you have a visual studio / build tools installation, then
> lld gets confused).
> 
> It was already solved in the nightly build, I downloaded some days ago.
> 
> Kind regards
> André

I think this happens because the Windows SDK is detected, but VC is not. As the replacement import libraries for both are in the dmd\windows\lib64\mingw folder, adding it to the library search path would be causing some bad mixture of libraries.

VC is probably no longer detected because recent versions of the VS installations do not write an expected registry key, but assume the COM API to be used for detection (as added by https://github.com/dlang/dmd/pull/9243).

So pedantically, this is not a regression in dmd, but a changed environment. You should still be able to link when running the vcvarsall.bat to setup the VS/VC environment variables.
February 06
On Wednesday, 6 February 2019 at 08:37:29 UTC, Rainer Schuetze wrote:
>
>
> On 05/02/2019 11:53, Andre Pany wrote:
>> [...]
>
> I think this happens because the Windows SDK is detected, but VC is not. As the replacement import libraries for both are in the dmd\windows\lib64\mingw folder, adding it to the library search path would be causing some bad mixture of libraries.
>
> VC is probably no longer detected because recent versions of the VS installations do not write an expected registry key, but assume the COM API to be used for detection (as added by https://github.com/dlang/dmd/pull/9243).
>
> So pedantically, this is not a regression in dmd, but a changed environment. You should still be able to link when running the vcvarsall.bat to setup the VS/VC environment variables.

In my case I want to use LLD for D. I had to install the Build Tools for Python Development and this broke D (2.084.0). The mentioned errors occurs.

Kind regards
Andre