Thread overview
Build fails on Linux Mint 21
Oct 02
torhu
Oct 03
torhu
Oct 17
torhu
October 02

I get this when trying to do a 64-bit build:

Linking...
../../.dub/packages/dwt-1.0.5_swt-3.4.1/dwt/org.eclipse.swt.gtk.linux.x86/src/org/eclipse/swt/program/Program.d:263: error: undefined reference to 'gnome_icon_theme_new'
../../.dub/packages/dwt-1.0.5_swt-3.4.1/dwt/org.eclipse.swt.gtk.linux.x86/src/org/eclipse/swt/program/Program.d:704: error: undefined reference to 'gnome_vfs_init'
../../.dub/packages/dwt-1.0.5_swt-3.4.1/dwt/org.eclipse.swt.gtk.linux.x86/src/org/eclipse/swt/program/Program.d:689: error: undefined reference to 'gnome_icon_lookup'
../../.dub/packages/dwt-1.0.5_swt-3.4.1/dwt/org.eclipse.swt.gtk.linux.x86/src/org/eclipse/swt/program/Program.d:692: error: undefined reference to 'gnome_icon_theme_lookup_icon'
collect2: error: ld returned 1 exit status
Error: /usr/bin/cc failed with status: 1
/usr/bin/ldc2 failed with exit code 1.

I am not able to find libgnomeui-dev, maybe that's all that's missing? If anyone has a DWT fork without that dependency, that would be great.

October 03

On Sunday, 2 October 2022 at 22:08:39 UTC, torhu wrote:

>

I am not able to find libgnomeui-dev, maybe that's all that's missing? If anyone has a DWT fork without that dependency, that would be great.

I got it to build by using the 4.7 branch instead. Now I get a segfault at startup, which seems to come from a Display.getDefault() call in a module constructor.

October 17

On Monday, 3 October 2022 at 01:27:23 UTC, torhu wrote:

>

I got it to build by using the 4.7 branch instead. Now I get a segfault at startup, which seems to come from a Display.getDefault() call in a module constructor.

Fixed that one. Now I found out that Display.syncExec runs the Runnable in the wrong thread. Anyone got a fix for this issue?