Thread overview
Cannot compile hello word out of the box in Visual D
December 10
I installed dmd, Visual D, but cannot compile project in VS.

VC\bin\link.exe is missing. But I really don't know what to do. Do I need to install something? Or change project settings?

I would also like to debug D apps in Visual D.

From command line, dmd compiles and runs the app just fine.

Thank you.



Details:

Build Log
Building Win32\Debug\TestDApp1.exe
Command Line

set PATH=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\bin;C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE;C:\Program Files (x86)\Windows Kits\10\bin\x86;C:\Users\IBM_ADMIN\Desktop\Soft\D\dmd2\windows\bin;%PATH%
set DMD_LIB=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\lib;C:\Program Files (x86)\Windows Kits\10\lib\10.0.14393.0\um\x86
set VCINSTALLDIR=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\
set VSINSTALLDIR=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\
set WindowsSdkDir=C:\Program Files (x86)\Windows Kits\10\
set WindowsSdkVersion=10.0.14393.0
set UniversalCRTSdkDir=C:\Program Files (x86)\Windows Kits\10\
set UCRTVersion=10.0.14393.0
"C:\Program Files (x86)\VisualD\pipedmd.exe" -deps Win32\Debug\TestDApp1.dep dmd -m32mscoff -g -gf -debug -X -Xf"Win32\Debug\TestDApp1.json" -c -of"Win32\Debug\TestDApp1.obj" TestDApp1.d
if %errorlevel% neq 0 goto reportError

set LIB=C:\Users\IBM_ADMIN\Desktop\Soft\D\dmd2\windows\bin\..\lib32mscoff
echo. > C:\Users\IBM_ADMIN\Desktop\Moje\TestDApp1\TestDApp1\Win32\Debug\TestDApp1.link.rsp
echo "Win32\Debug\TestDApp1.obj" /OUT:"Win32\Debug\TestDApp1.exe" user32.lib  >> C:\Users\IBM_ADMIN\Desktop\Moje\TestDApp1\TestDApp1\Win32\Debug\TestDApp1.link.rsp
echo kernel32.lib /LIBPATH:"C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\lib" /LIBPATH:"C:\Program Files (x86)\Windows Kits\10\lib\10.0.14393.0\um\x86" /DEBUG /PDB:"Win32\Debug\TestDApp1.pdb" /INCREMENTAL:NO /NOLOGO /noopttls /NODEFAULTLIB:libcmt libcmtd.lib /SUBSYSTEM:CONSOLE >> C:\Users\IBM_ADMIN\Desktop\Moje\TestDApp1\TestDApp1\Win32\Debug\TestDApp1.link.rsp
"C:\Program Files (x86)\VisualD\mb2utf16.exe" C:\Users\IBM_ADMIN\Desktop\Moje\TestDApp1\TestDApp1\Win32\Debug\TestDApp1.link.rsp

"C:\Program Files (x86)\VisualD\pipedmd.exe" -msmode -deps Win32\Debug\TestDApp1.lnkdep "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\bin\link.exe" @C:\Users\IBM_ADMIN\Desktop\Moje\TestDApp1\TestDApp1\Win32\Debug\TestDApp1.link.rsp
if %errorlevel% neq 0 goto reportError
if not exist "Win32\Debug\TestDApp1.exe" (echo "Win32\Debug\TestDApp1.exe" not created! && goto reportError)

goto noError

:reportError
echo Building Win32\Debug\TestDApp1.exe failed!

:noError
Output

TRACKER : error TRK0005: Failed to locate: "C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC\bin\link.exe". The system cannot find the file specified.

Building Win32\Debug\TestDApp1.exe failed!
December 10
On Monday, 10 December 2018 at 09:56:24 UTC, Michal Minich wrote:
> I installed dmd, Visual D, but cannot compile project in VS.
>
> VC\bin\link.exe is missing. But I really don't know what to do. Do I need to install something? Or change project settings?

It looks like Visual D's paths aren't set correctly.

In Visual Studio, go to Tools > Options > Projects and Solutions > Visual D Settings > DMD Directories. To the right of "Executable paths" make sure this is listed: $(VCTOOLSINSTALLDIR)bin\HostX86\x86
December 10
> I installed dmd, Visual D, but cannot compile project in VS.

What version of Visual D? If downloaded by the dmd installer it is not the latest, see https://github.com/dlang/visuald/releases

On 10/12/2018 10:56, Michal Minich wrote:
> set VCINSTALLDIR=C:\Program Files (x86)\Microsoft Visual Studio\2017\Community\Common7\IDE\VC
This looks wrong to me, it is set to something else for me:

VCINSTALLDIR=C:\Program Files (x86)\Microsoft Visual
Studio\2017\Community\VC\

Instead VCIDEInstallDir is set to the same value as in your installation:

VCIDEInstallDir=C:\Program Files (x86)\Microsoft Visual
Studio\2017\Community\Common7\IDE\VC\

Maybe you did not install any C++ toolchain? If it is there you should also check the executable search path as John mentioned. There is also an explicit linker path setting which might point to a wrong location with your setting above.