Jump to page: 1 24  
Page
Thread overview
Weak Eco System?
May 16
Benro
May 16
burber
May 16
aberba
May 16
Benro
May 16
Basile B.
May 16
Benro
May 16
Basile B.
May 17
Benro
May 17
Basile B.
May 17
ezneh
May 17
aberba
May 17
juanjux
5 days ago
Mike B Johnson
5 days ago
Benro
5 days ago
bachmeier
[OT] Don't feed the troll
5 days ago
Timon Gehr
May 17
bachmeier
May 18
Manu
May 19
qznc
5 days ago
qznc
3 days ago
Manu
May 16
A quick summary trying to get D and a some IDEs running on a Windows environment.

Installation of D fairly standard and no issues.


**Jetbrain intellij-dlanguage:**

* Installed Intellij
* Found the dlanguage plugin and installed

Then found out it requires Dub, DCD, Dscanner, DFmt ..

And here the "work" begins. It already requires GIT to be installed on the host system.

Then it require knowledge how to clone the projects and building them. Several of the projects have out of date information.

DCD required:
"dub build --build=release --config=client --force"
"dub build --build=release --config=server --force"

Forced was needed or compilation failed on different versions on 3th party packages.

Dfmt required:
"git submodule update --init --recursive" and then build.bat

Dscanner:
Needed dub to build. Its build.bat was out of date and gave errors.

After these steps the files got linked into the dlanguage plugin. Partially they worked and also gave errors: "com.google.gson.stream.MalformedJsonException: Use JsonReader.setLenient(true) to accept malformed JSON at line 1 column 5 path $".

Usability: 4/10 ( Color Syntax worked, Some type hinting worked )


**Visual Studio Code dlang-vscode:**

* Installed.
* Errors on fetching several of the dependances (dcd etc). As those dependances did not get installed, most enhancements did not work.

Usability: 1/10 ( Color Syntax worked )


**Visual Studio Code code-d:**

* Installed.

* Gave warning to install Workspaces-d. Auto installed Workspaces-d. Restarted.
* Gave warning for DUB, DCD, etc ... Auto installed all dependances.

Again issues. Code formatting etc worked but no code hinting or any advanced features. Looks more or less like a colored editor with formatting. Looked for solution, nothing found.

Usability: 2/10 ( Color Syntax, Code formatting worked )

4 Hours work. Discouraged and gave up after this.


Its not the my first time trying to get D working as a production environment ( beyond just command line + simple color editor ). A lot of times it comes down to different version plugins, bugs / out of date with the main DMD version, main git code not stable/tested properly.

And its not my attempt trying to get D editors set up in a acceptable way. Always gave up and back to C# because "it just works".

These steps are too much for people who want to quickly check out D and its Editor/IDE support. If D wants to showcase itself to new developers or developers coming from different languages there is a need for a more unified environment.

------------------------------

My question/suggestion becomes why are DCD, Dscanner, DFormat etc not part of the default installation.

* This means that they can be tested for release with that version of D.
* It means that Editor/IDE authors can predict where these files are.
* It bypasses a lot of issues where people download the "latest" version from GIT and run into issues.

Its "Win Win" for all ...
May 16
On Tuesday, 16 May 2017 at 14:51:29 UTC, Benro wrote:
> A quick summary trying to get D and a some IDEs running on a Windows environment.
>
> [...]

I've tried many different IDEs, some are alright but most don't have what I personally think they should have. I think if this language had a solid IDE similar to IntelliJ and/or Eclipse, it would be great. I can't blame anyone for the plugins being outdated or buggy because it's community ran, there isn't much more you can expect. I'm one of those people who depend on a good IDE (used Vim and Emacs maybe once or twice) and I think that D could get really popular if it had better IDE support.
May 16
On Tuesday, 16 May 2017 at 14:51:29 UTC, Benro wrote:
> A quick summary trying to get D and a some IDEs running on a Windows environment.
>
> [...]

I just install sublime text editor and that all the tooling I ever needed. Sublime has a Dkit plugin too. I agree to bundling the tools together though.
May 16
On Tuesday, 16 May 2017 at 14:51:29 UTC, Benro wrote:
> **Visual Studio Code code-d:**
>
> * Installed.
>
> * Gave warning to install Workspaces-d. Auto installed Workspaces-d. Restarted.
> * Gave warning for DUB, DCD, etc ... Auto installed all dependances.
>
> Again issues. Code formatting etc worked but no code hinting or any advanced features. Looks more or less like a colored editor with formatting. Looked for solution, nothing found.
>
> Usability: 2/10 ( Color Syntax, Code formatting worked )
>
> 4 Hours work. Discouraged and gave up after this.

Sorry to hear that, usually the issue is directly logged to the developer tools (Ctrl-Shift-P -> Toggle Developer Tools) which you can just send in as issue on https://github.com/Pure-D/code-d if it is broken. It should always have basic auto completion for the current file and project auto completion for dub projects (but not sub packages) as well as linting the file when saving and even showing build errors when using dub. If it can't find the D import directory (std, core) then it should also show a warning to you so I don't really know what went wrong without the log. In the next big version update the log will be easier to access by the output tab in vscode.
May 16
On Tuesday, 16 May 2017 at 14:51:29 UTC, Benro wrote:
>
> Then found out it requires Dub, DCD, Dscanner, DFmt ..
>
> And here the "work" begins. It already requires GIT to be installed on the host system.
>
> Then it require knowledge how to clone the projects and building them. Several of the projects have out of date information.
>
> DCD required:
> "dub build --build=release --config=client --force"
> "dub build --build=release --config=server --force"
>
> Forced was needed or compilation failed on different versions on 3th party packages.
>
> Dfmt required:
> "git submodule update --init --recursive" and then build.bat
>
> Dscanner:
> Needed dub to build. Its build.bat was out of date and gave errors.

If you have problems with Hackerpilot's programs don't forget to report an issue.
His tools are now maintained by an organization people (https://github.com/dlang-community) and fix are merged fast.

For example the build.bat fix could have been made and merged in 10 min. if you would have took the time to report it!
May 16
On Tuesday, 16 May 2017 at 17:14:49 UTC, Basile B. wrote:
> For example the build.bat fix could have been made and merged in 10 min. if you would have took the time to report it!

First of all. ! is not appreciated. This is considered yelling.

Second. The dscanner issue was listed on there own Git "build.bat is out of date" for over 3 months. So please do not poke people about not reporting a issue, that is already known for 3 months. And in case of dscanner, using dup worked just as well but you need to figure it our yourself.

And for your information, i reported SEVERAL issues each time i gave D a try. More then half the times it ended up being a issue with dcd or dscanner. Why do i need to defend myself from you? Very welcoming attitude.

Some authors responded fast but had been unable to fix the issue because it was:

* DCD ( Twice ).
* Incompatibility between D versions, plugin was not updated. Solved it with running the older D version.
* A 3th party plugin, that was use was incompatibility ( one with a version issue and one where it did not fix a D regression issue ).

I do not take away from the editor authors there hard word but when they need to rely on dscanner, dcd etc for stability, they end up with bug reports that are constantly not there issue.

Getting blasted for supposedly not reporting bugs irks the hell out of me. The Code-d issue i have nothing to report because there is not a single error message. It simply does not work. Output is clean. Workspace-d reported no issue. Bug report: It does not work. Yea, the author will love that one. O_o

The IntelliJ IDEA, yea, i need to report that one but i was tired after the whole installation cycle. I tried that one in the end. That was my bad.

I rather post it here and bring focus on the whole issue then simply report it on git and then months later coming back to see nothing has changed ( again and again ).
May 16
On Tuesday, 16 May 2017 at 16:31:54 UTC, WebFreak001 wrote:
> Sorry to hear that, usually the issue is directly logged to the developer tools (Ctrl-Shift-P -> Toggle Developer Tools) which you can just send in as issue on https://github.com/Pure-D/code-d if it is broken. It should always have basic auto completion for the current file and project auto completion for dub projects (but not sub packages) as well as linting the file when saving and even showing build errors when using dub. If it can't find the D import directory (std, core) then it should also show a warning to you so I don't really know what went wrong without the log. In the next big version update the log will be easier to access by the output tab in vscode.

I will take another look at it tomorrow. The installation was at my work.

At home i need to deal with another issue, so i can not reproduce it. D installed on USB stick. Can not uninstall ( stick at work ). Can not install new version because the old one can not uninstall. Yay...
May 16
On Tuesday, 16 May 2017 at 21:08:34 UTC, Benro wrote:
> On Tuesday, 16 May 2017 at 17:14:49 UTC, Basile B. wrote:
>> For example the build.bat fix could have been made and merged in 10 min. if you would have took the time to report it!
>
> First of all. ! is not appreciated. This is considered yelling.
>
> Second. The dscanner issue was listed on there own Git "build.bat is out of date" for over 3 months. So please do not poke people about not reporting a issue, that is already known for 3 months. And in case of dscanner, using dup worked just as well but you need to figure it our yourself.
>
> And for your information, i reported SEVERAL issues each time i gave D a try. More then half the times it ended up being a issue with dcd or dscanner. Why do i need to defend myself from you? Very welcoming attitude.
>
> [...]
> 
> Getting blasted for supposedly not reporting bugs irks the hell out of me.

I didn't blast you, don't feel attacked by a simple exclamation mark: you didn't give all the information about the D-Scanner "build.bat" bug. I was only speaking about this.

The fact is as a user I'm quite satisfied with the state of the ecosystem.

May 16
On Tuesday, 16 May 2017 at 21:08:34 UTC, Benro wrote:
> On Tuesday, 16 May 2017 at 17:14:49 UTC, Basile B. wrote:
>> For example the build.bat fix could have been made and merged in 10 min. if you would have took the time to report it!
>
> First of all. ! is not appreciated. This is considered yelling.

Grow up!!!!!

! is not yelling. It makes no sound, has no meaning, and only exists to insert in to tight anuses that have no life.



May 16
On Tuesday, May 16, 2017 23:17:10 Mike B Johnson via Digitalmars-d wrote:
> On Tuesday, 16 May 2017 at 21:08:34 UTC, Benro wrote:
> > On Tuesday, 16 May 2017 at 17:14:49 UTC, Basile B. wrote:
> >> For example the build.bat fix could have been made and merged in 10 min. if you would have took the time to report it!
> >
> > First of all. ! is not appreciated. This is considered yelling.
>
> Grow up!!!!!
>
> ! is not yelling. It makes no sound, has no meaning, and only exists to insert in to tight anuses that have no life.

Let's please be civil. It can be quite easy to misinterpet tone when dealing only with text, but it looks to me like there's too much overacting in this thread in general. Let's take the feedback and try and be constructive about it. And regardless of what someone else posted, insults are not appropriate here.

- Jonathan M Davis

« First   ‹ Prev
1 2 3 4